aboutsummaryrefslogtreecommitdiffstats
path: root/community/gsoap
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-10 12:43:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-10 12:45:35 +0000
commit7d03a5713b5e3e4df6c8388c830d5eaf879ed6d7 (patch)
tree0d1e53c3d48fca14ae6aa35f0ea74466ad2564e7 /community/gsoap
parent8fdf443375dff3361b2bfff3685368598b1dd566 (diff)
downloadaports-7d03a5713b5e3e4df6c8388c830d5eaf879ed6d7.tar.bz2
aports-7d03a5713b5e3e4df6c8388c830d5eaf879ed6d7.tar.xz
community/gsoap: upgrade to 2.8.45
Diffstat (limited to 'community/gsoap')
-rw-r--r--community/gsoap/APKBUILD14
-rw-r--r--community/gsoap/libressl.patch40
-rw-r--r--community/gsoap/musl-fixes.patch17
3 files changed, 59 insertions, 12 deletions
diff --git a/community/gsoap/APKBUILD b/community/gsoap/APKBUILD
index 13e3e7cd8a..2797a1d5e6 100644
--- a/community/gsoap/APKBUILD
+++ b/community/gsoap/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: <xmingske@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gsoap
-pkgver=2.8.36
-pkgrel=1
+pkgver=2.8.45
+pkgrel=0
arch="all"
pkgdesc='A cross-platform C and C++ SDK for SOAP/XML Web services'
license="GPL-2 gSOAP"
@@ -12,6 +12,7 @@ makedepends="autoconf automake bison flex zlib-dev libressl-dev libtool"
subpackages="$pkgname-dev"
source="http://downloads.sourceforge.net/project/gsoap2/gsoap-${pkgver%.*}/gsoap_$pkgver.zip
musl-fixes.patch
+ libressl.patch
"
builddir="$srcdir"/$pkgname-${pkgver%.*}
@@ -33,9 +34,6 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="6f500965431eb253271cb087b153493e gsoap_2.8.36.zip
-ce945058c898a360951c11d574699872 musl-fixes.patch"
-sha256sums="20f70db768062e094ec3749073bfc4103cacaac8cab2cdbd624634ae496eef21 gsoap_2.8.36.zip
-db122e51e629121ce295f76e1f0d90595c5450c42d46342def50c56696150363 musl-fixes.patch"
-sha512sums="6ebe479b91a1df92a7ac9019762d0a225f255ce9a772d56a50bccfe9b16645d1ee3bb38e4d2dd2fd960a3f9feee152204158e8002813db8d9ed6b2453c096287 gsoap_2.8.36.zip
-4c96126bdd9263fd686e7e9283e80d751f209a03d5920b9c3763851a1a8a48d48e1740eaa9269f05a1b3128a9476323a2359904dfd4c2ac43f5cee5ff64e4b98 musl-fixes.patch"
+sha512sums="db45f2f8403143387f2860339a77695079fd3224700791846eb436d510a1008fe217c85b61b980340a4982d20ed0fef87dfd8d3de07be9953b627b539ca4af2a gsoap_2.8.45.zip
+5093b720084f7bb72f6b0b25c982aaaf4f8c121b8b5e34690749ff40f5bd1ca1cc9e5adb9c597f0bfc432ca910b226f75cf22a6403820f93051e8e7191e74b07 musl-fixes.patch
+a0892700b55562880a58cd8411fb3386a2ae1785c9212a59d0d1c8ccdfa86553bb8d6fb3dd6c923453a1a47c586edbc924c6e7bd4f2436948693e39bd3b1ec73 libressl.patch"
diff --git a/community/gsoap/libressl.patch b/community/gsoap/libressl.patch
new file mode 100644
index 0000000000..f0aff5ba21
--- /dev/null
+++ b/community/gsoap/libressl.patch
@@ -0,0 +1,40 @@
+diff --git a/gsoap/plugin/smdevp.c b/gsoap/plugin/smdevp.c
+index a42d7be..193f470 100644
+--- a/gsoap/plugin/smdevp.c
++++ b/gsoap/plugin/smdevp.c
+@@ -479,7 +479,7 @@ soap_smd_init(struct soap *soap, struct soap_smd_data *data, int alg, const void
+ /* allocate and init the OpenSSL HMAC or EVP_MD context */
+ if ((alg & SOAP_SMD_ALGO) == SOAP_SMD_HMAC)
+ {
+-#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
++#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
+ data->ctx = (void*)SOAP_MALLOC(soap, sizeof(HMAC_CTX));
+ if (data->ctx)
+ HMAC_CTX_init((HMAC_CTX*)data->ctx);
+@@ -489,7 +489,7 @@ soap_smd_init(struct soap *soap, struct soap_smd_data *data, int alg, const void
+ }
+ else
+ {
+-#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
++#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
+ data->ctx = (void*)SOAP_MALLOC(soap, sizeof(EVP_MD_CTX));
+ if (data->ctx)
+ EVP_MD_CTX_init((EVP_MD_CTX*)data->ctx);
+@@ -642,7 +642,7 @@ soap_smd_final(struct soap *soap, struct soap_smd_data *data, char *buf, int *le
+ *len = (int)n;
+ }
+ /* cleanup */
+-#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
++#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
+ if ((data->alg & SOAP_SMD_ALGO) == SOAP_SMD_HMAC)
+ HMAC_CTX_cleanup((HMAC_CTX*)data->ctx);
+ else
+@@ -687,7 +687,7 @@ soap_smd_check(struct soap *soap, struct soap_smd_data *data, int ok, const char
+ }
+ if (data->ctx)
+ {
+-#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
++#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(OPENSSL_VERSION_NUMBER)
+ if ((data->alg & SOAP_SMD_ALGO) == SOAP_SMD_HMAC)
+ HMAC_CTX_cleanup((HMAC_CTX*)data->ctx);
+ else
diff --git a/community/gsoap/musl-fixes.patch b/community/gsoap/musl-fixes.patch
index a6836ae9cf..52ed6efc7a 100644
--- a/community/gsoap/musl-fixes.patch
+++ b/community/gsoap/musl-fixes.patch
@@ -9,14 +9,23 @@
return strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* GNU-specific */
# else
strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* XSI-compliant */
---- gsoap-2.8.orig/gsoap/stdsoap2.h
-+++ gsoap-2.8/gsoap/stdsoap2.h
-@@ -859,7 +859,7 @@
+--- ./gsoap/stdsoap2.h.orig
++++ ./gsoap/stdsoap2.h
+@@ -677,7 +677,7 @@
+ # define SOAP_LOCALE(soap) ((soap)->c_locale ? (soap)->c_locale : ((soap)->c_locale = _create_locale(LC_ALL, "C")))
+ # define SOAP_FREELOCALE(soap) (void)((soap)->c_locale && (_free_locale((soap)->c_locale), ((soap)->c_locale = NULL)))
+ # else
+-# if !defined(CYGWIN)
++# if !defined(CYGWIN) && defined(__GLIBC__)
+ # include <xlocale.h>
+ # else
+ # undef HAVE_STRTOF_L
+@@ -943,7 +943,7 @@
# endif
#elif defined(SOCKLEN_T)
# define SOAP_SOCKLEN_T SOCKLEN_T
-#elif defined(__socklen_t_defined) || defined(_SOCKLEN_T) || defined(CYGWIN) || defined(FREEBSD) || defined(__FreeBSD__) || defined(OPENBSD) || defined(__QNX__) || defined(QNX) || defined(OS390) || defined(__ANDROID__) || defined(_XOPEN_SOURCE)
+#elif defined(__socklen_t_defined) || defined(_SOCKLEN_T) || defined(CYGWIN) || defined(FREEBSD) || defined(__FreeBSD__) || defined(OPENBSD) || defined(__QNX__) || defined(QNX) || defined(OS390) || defined(__ANDROID__) || defined(_XOPEN_SOURCE) || defined (LINUX)
# define SOAP_SOCKLEN_T socklen_t
- #elif defined(IRIX) || defined(WIN32) || defined(__APPLE__) || defined(SUN_OS) || defined(OPENSERVER) || defined(TRU64) || defined(VXWORKS) || defined(HP_UX)
+ #elif defined(IRIX) || defined(WIN32) || defined(__APPLE__) || defined(SUN_OS) || defined(OPENSERVER) || defined(TRU64) || defined(VXWORKS)
# define SOAP_SOCKLEN_T int