aboutsummaryrefslogtreecommitdiffstats
path: root/community/gtk-vnc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-16 12:52:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-16 13:52:48 +0000
commitb0fc147aacf8769b56a06c00acc227f998c7b93e (patch)
tree24451e1dd9713a0850e8a71632972034f0713af5 /community/gtk-vnc
parent2b2a863ad02b1364c94c869c7f2d4c0024286db6 (diff)
downloadaports-b0fc147aacf8769b56a06c00acc227f998c7b93e.tar.bz2
aports-b0fc147aacf8769b56a06c00acc227f998c7b93e.tar.xz
community/gtk-vnc: move from main
Diffstat (limited to 'community/gtk-vnc')
-rw-r--r--community/gtk-vnc/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/gtk-vnc/APKBUILD b/community/gtk-vnc/APKBUILD
new file mode 100644
index 0000000000..8552f8b67b
--- /dev/null
+++ b/community/gtk-vnc/APKBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gtk-vnc
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="A VNC viewer widget for GTK"
+url="http://live.gnome.org/gtk-vnc"
+arch="all"
+license="LGPL"
+depends_dev="gtk+3.0-dev gnutls-dev glib-dev"
+makedepends="$depends_dev gettext-dev intltool expat-dev
+ libgcrypt-dev libgpg-error-dev cyrus-sasl-dev perl-text-csv
+ gobject-introspection-dev vala sed"
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+subpackages="$pkgname-dev gvncviewer $pkgname-lang $pkgname-doc"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+}
+
+build () {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --with-examples \
+ --enable-introspection \
+ --with-gtk=3.0 \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+gvncviewer() {
+ pkgdesc="Demo application for gtk-vnc"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+md5sums="bc7b79c4b8124294dacf91b8128a158c gtk-vnc-0.5.4.tar.xz"
+sha256sums="488aa97a76ce6868160699cd45d4a0ee0fe6f0ad4631737c6ddd84450f6c9ce7 gtk-vnc-0.5.4.tar.xz"
+sha512sums="068f7e29d40c677c9453364e33ab3a57e155dd0715299c8dee3f9933ecdb2e3bc4aea6dd722f5bc846d9b883e4f5a6de7b46742f004b348a551100ea7720da61 gtk-vnc-0.5.4.tar.xz"