aboutsummaryrefslogtreecommitdiffstats
path: root/community/hexchat/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-06-12 10:22:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-12 10:22:18 +0000
commitcee1bf308e14708c360e65b02fbad171d73baff1 (patch)
tree3f4712d21b9ec4f16443799199eb4cf80e5326b8 /community/hexchat/APKBUILD
parenta2a3fe0376a647250bc20d67ff1567e88277810d (diff)
downloadaports-cee1bf308e14708c360e65b02fbad171d73baff1.tar.bz2
aports-cee1bf308e14708c360e65b02fbad171d73baff1.tar.xz
community/hexchat: move from main
Diffstat (limited to 'community/hexchat/APKBUILD')
-rw-r--r--community/hexchat/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/community/hexchat/APKBUILD b/community/hexchat/APKBUILD
new file mode 100644
index 0000000000..920dbe6226
--- /dev/null
+++ b/community/hexchat/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=hexchat
+pkgver=2.14.2
+pkgrel=1
+pkgdesc="Graphical IRC client based on XChat"
+url="https://hexchat.github.io"
+arch="all !armhf !armv7"
+license="GPL-2.0-or-later"
+depends=""
+makedepends="dbus-glib-dev gtk+2.0-dev iso-codes libnotify-dev libproxy-dev
+ openssl-dev libsexy-dev libxml2-dev lua5.3-dev meson python3-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-lang $pkgname-python:_python"
+source="https://dl.hexchat.net/$pkgname/$pkgname-$pkgver.tar.xz
+ force-meson-build-order.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ meson --prefix=/usr \
+ -Dwith-perl=false \
+ -Dwith-lua=lua5.3 \
+ -Dwith-sysinfo=false \
+ -Dwith-libcanberra=false \
+ build_dir/
+ ninja -C build_dir/
+}
+
+package() {
+ cd "$builddir"
+ DESTDIR="$pkgdir" ninja -C build_dir/ install
+
+ # not worth a -dev pkg
+ rm -fr "$pkgdir"/usr/include
+ rm -fr "$pkgdir"/usr/lib/pkgconfig
+}
+
+_python() {
+ pkgdesc="Python plugin for hexchat"
+ mkdir -p "$subpkgdir"/usr/lib/hexchat/plugins
+ mv "$pkgdir"/usr/lib/hexchat/plugins/python.so \
+ "$subpkgdir"/usr/lib/hexchat/plugins
+}
+
+sha512sums="488799700e439a137ad469f618cb1abf75d1f1ebf223c750d658004ef7b2c728543a5a9ae4e6317d6447428dc59e12dded619346a5d8bba12c92dab653512fca hexchat-2.14.2.tar.xz
+f579622330391fbce798bf9b0e5c1d07975a188b79f7160ab8c921b7df92b2d31444f30d6f62b7b08f7543a4ef40975ecf53705903374b73069bb369967491c5 force-meson-build-order.patch"