aboutsummaryrefslogtreecommitdiffstats
path: root/community/hhpc
diff options
context:
space:
mode:
author7heo <7heo@mail.com>2016-08-29 15:03:47 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-29 15:59:44 +0200
commit79843a90428748ae7c30c1209f28a6e1b38591ca (patch)
tree8af62f53ac8a9133ac6ec8b85c5cb9f0642cc32e /community/hhpc
parent3271dd21335a003c2f08c4afaf22e4b262e8d968 (diff)
downloadaports-79843a90428748ae7c30c1209f28a6e1b38591ca.tar.bz2
aports-79843a90428748ae7c30c1209f28a6e1b38591ca.tar.xz
unmaintained/hhpc: move to community
Diffstat (limited to 'community/hhpc')
-rw-r--r--community/hhpc/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/hhpc/APKBUILD b/community/hhpc/APKBUILD
new file mode 100644
index 0000000000..d435c53098
--- /dev/null
+++ b/community/hhpc/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: 7heo <7heo@mail.com>
+# Maintainer: 7heo <7heo@mail.com>
+pkgname=hhpc
+pkgver=0.3.2
+pkgrel=0
+pkgdesc="An utility to automatically hide the mouse pointer after a specified delay of inactivity"
+url="https://github.com/aktau/hhpc"
+arch="all"
+license="3-clause BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libx11-dev"
+install=""
+subpackages=""
+source="hhpc-$pkgver.tar.gz::https://github.com/7heo/hhpc/archive/v$pkgver.tar.gz"
+_builddir="$srcdir"/hhpc-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="2d579207ce5d6b3fbbfa4b81109ffaa3 hhpc-0.3.2.tar.gz"
+sha256sums="7701e20143133317d0746b6f723bdd9bff92fb7c4bd9af745e632444dbbc3afa hhpc-0.3.2.tar.gz"
+sha512sums="c07a054c1826cff530f27c047e52bc982bfe057fa5c92dfd3af42750b4aa8369c614529b62e701c5f9199749659f47e3c56bcbc68b14a0b86b35c9a031d80417 hhpc-0.3.2.tar.gz"