aboutsummaryrefslogtreecommitdiffstats
path: root/community/hidapi
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-11-10 13:15:19 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-11-10 13:21:29 +0100
commitf9e819da0653c1628f30b3a4d460fccedb51000f (patch)
tree2b294926b9516bc7239e71ed70f463e76529d2f8 /community/hidapi
parent710c323db8c250364b2f6880bb2c0afd87062835 (diff)
downloadaports-f9e819da0653c1628f30b3a4d460fccedb51000f.tar.bz2
aports-f9e819da0653c1628f30b3a4d460fccedb51000f.tar.xz
community/hidapi: move from testing and take maintainership
Diffstat (limited to 'community/hidapi')
-rw-r--r--community/hidapi/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/hidapi/APKBUILD b/community/hidapi/APKBUILD
new file mode 100644
index 0000000000..56128f2336
--- /dev/null
+++ b/community/hidapi/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=hidapi
+pkgver=0.9.0
+pkgrel=2
+pkgdesc="Simple library for communicating with USB and Bluetooth HID devices"
+url="https://github.com/libusb/hidapi"
+arch="all"
+license="custom"
+options="!check"
+makedepends="libusb-dev libtool eudev-dev linux-headers autoconf automake"
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/libusb/$pkgname/archive/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+
+ ./bootstrap
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
+ mv "$pkgdir"/usr/share/doc/$pkgname/LICENSE* \
+ "$pkgdir"/usr/share/licenses/$pkgname
+}
+
+sha512sums="d9f28d394b78daece7d2dfb946e62349a56b388b3a06241585c6fad5a4e24dc914723de6c0f12a9e51cd23fb245f6b5ac9b3721319646d5ba5912bbe0a3f9a52 hidapi-0.9.0.tar.gz"