aboutsummaryrefslogtreecommitdiffstats
path: root/community/html-xml-utils
diff options
context:
space:
mode:
authorPrzemyslaw Pawelczyk <przemoc@zoho.com>2016-08-27 00:06:37 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-08-26 22:09:42 +0000
commit3b3a846dea118a749f81d1ca6406054a53ce8146 (patch)
tree41d02bb995da40ca7ce56a2e5f97a83f71a3e5cd /community/html-xml-utils
parented10cca4f0afaae26d09a5479ad68c6fa2f21014 (diff)
downloadaports-3b3a846dea118a749f81d1ca6406054a53ce8146.tar.bz2
aports-3b3a846dea118a749f81d1ca6406054a53ce8146.tar.xz
community/html-xml-utils: Move from testing.
Diffstat (limited to 'community/html-xml-utils')
-rw-r--r--community/html-xml-utils/APKBUILD55
-rw-r--r--community/html-xml-utils/getopt-musl-fix.patch12
2 files changed, 67 insertions, 0 deletions
diff --git a/community/html-xml-utils/APKBUILD b/community/html-xml-utils/APKBUILD
new file mode 100644
index 0000000000..bbd7c33006
--- /dev/null
+++ b/community/html-xml-utils/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=html-xml-utils
+pkgver=7.0
+pkgrel=1
+pkgdesc="A number of simple utilities for manipulating HTML and XML files."
+url="https://www.w3.org/Tools/HTML-XML-utils/"
+arch="all"
+license="Custom"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="$url/$pkgname-$pkgver.tar.gz
+ getopt-musl-fix.patch"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ default_prepare || return 1
+ sed \
+ -e "/doc_DATA = COPYING/d" \
+ -i Makefile.in \
+ || return 1
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --disable-dependency-tracking \
+ || return 1
+
+ make \
+ || return 1
+}
+
+package() {
+ cd "$builddir"
+ make install \
+ DESTDIR="$pkgdir" \
+ || return 1
+ install -D -m 644 \
+ COPYING \
+ "$pkgdir"/usr/share/licenses/$pkgname/COPYING \
+ || return 1
+}
+
+md5sums="b513432f7f084c158495815cc5118f0f html-xml-utils-7.0.tar.gz
+06e2741e3277a4329e8e312236340fba getopt-musl-fix.patch"
+sha256sums="e7d30de4fb4731f3ecd4622ac30db9fb82e1aa0ab190ae13e457360eea9460b0 html-xml-utils-7.0.tar.gz
+a30b4f34c4f2fc3b5ad6606c3e1d6d0f6a08ff1553113d85caee85b7bc336a05 getopt-musl-fix.patch"
+sha512sums="305578c135972c64e048962734c4794ed3a386a4bc3194cb14277fbe5bfcdb01a13a32bcf751d1216b3e89244ab778235c8cfb12d412fdfe1bf26229b5e23732 html-xml-utils-7.0.tar.gz
+7b6d03798e634a72402916cdfaf69668bf19d0dc6d629860c798a6468f8077906e3ada6d1ff390cebba505ccd118cfa7f7b2e23301ac72573bde4b4eb14c94ce getopt-musl-fix.patch"
diff --git a/community/html-xml-utils/getopt-musl-fix.patch b/community/html-xml-utils/getopt-musl-fix.patch
new file mode 100644
index 0000000000..dc76c0cf95
--- /dev/null
+++ b/community/html-xml-utils/getopt-musl-fix.patch
@@ -0,0 +1,12 @@
+diff --git a/hxnum.c b/hxnum.c
+index d72bac6..deaba9b 100644
+--- a/hxnum.c
++++ b/hxnum.c
+@@ -28,6 +28,7 @@
+ # endif
+ #endif
+ #include <stdlib.h>
++#include <getopt.h>
+ #include <assert.h>
+ #include "export.h"
+ #include "types.e"