aboutsummaryrefslogtreecommitdiffstats
path: root/community/hyphen
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-05-18 07:34:17 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-05-18 12:52:04 +0000
commit36678de208f015aa651e1f77c16fce9e675db98e (patch)
tree21c09629dd85d00dcb9fa51065a5f35269ae1580 /community/hyphen
parent327a5b30eb8d28e7a2d4fa874c6c24947f05a2cd (diff)
downloadaports-36678de208f015aa651e1f77c16fce9e675db98e.tar.bz2
aports-36678de208f015aa651e1f77c16fce9e675db98e.tar.xz
community/hyphen: moved from main
Diffstat (limited to 'community/hyphen')
-rw-r--r--community/hyphen/APKBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/community/hyphen/APKBUILD b/community/hyphen/APKBUILD
new file mode 100644
index 0000000000..158d3112cb
--- /dev/null
+++ b/community/hyphen/APKBUILD
@@ -0,0 +1,66 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=hyphen
+pkgver=2.8.8
+pkgrel=0
+pkgdesc="Library for high quality hyphenation and justification"
+url="http://hunspell.sourceforge.net/"
+arch="all"
+license="GPL2+ LGPL2+ MPL 1.1"
+subpackages="$pkgname-dev $pkgname-en"
+depends=""
+depends_dev="perl"
+makedepends="$depends_dev"
+source="http://downloads.sourceforge.net/hunspell/$pkgname-$pkgver.tar.gz
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+dev() {
+ default_dev
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+en() {
+ pkgdesc="English hyphenation rules"
+ depends="hyphen"
+
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/share "$subpkgdir"/usr
+
+ for lang in en_AG en_AU en_BS en_BW en_BZ en_CA en_DK en_GB en_GH en_HK en_IE en_IN en_JM en_NA en_NZ en_PH en_SG en_TT en_ZA en_ZW; do
+ ln -s hyph_en_US.dic "$subpkgdir"/usr/share/hyphen/hyph_$lang.dic
+ done
+
+}
+
+md5sums="5ade6ae2a99bc1e9e57031ca88d36dad hyphen-2.8.8.tar.gz"
+sha256sums="304636d4eccd81a14b6914d07b84c79ebb815288c76fe027b9ebff6ff24d5705 hyphen-2.8.8.tar.gz"
+sha512sums="ee514952be56869840b70fb74f60eba14dc4de246733ff8705492367e8cf00c485f8778a9d5a7ba374c988d4ac9fedbe75826dc559e1b62465dbfba21f6ce7de hyphen-2.8.8.tar.gz"