aboutsummaryrefslogtreecommitdiffstats
path: root/community/hyphen
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-07-13 21:41:25 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-07-13 23:29:55 +0000
commitb719073b97e4cfc3e56ecc42517792e69d38fd77 (patch)
tree5980eaa646ac21633b1cd2f55b7491654f0a45c3 /community/hyphen
parent6eea369b22c77cc6e50124d3994e7a728b100f44 (diff)
downloadaports-b719073b97e4cfc3e56ecc42517792e69d38fd77.tar.bz2
aports-b719073b97e4cfc3e56ecc42517792e69d38fd77.tar.xz
community/hyphen: modernize APKBUILD
Diffstat (limited to 'community/hyphen')
-rw-r--r--community/hyphen/APKBUILD25
1 files changed, 7 insertions, 18 deletions
diff --git a/community/hyphen/APKBUILD b/community/hyphen/APKBUILD
index b515530fc1..6025435fd9 100644
--- a/community/hyphen/APKBUILD
+++ b/community/hyphen/APKBUILD
@@ -8,38 +8,27 @@ url="http://hunspell.sourceforge.net/"
arch="all"
license="GPL2+ LGPL2+ MPL 1.1"
subpackages="$pkgname-dev $pkgname-en"
-depends=""
depends_dev="perl"
makedepends="$depends_dev"
-source="http://downloads.sourceforge.net/hunspell/$pkgname-$pkgver.tar.gz
- "
+source="http://downloads.sourceforge.net/hunspell/$pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--disable-static \
--disable-dependency-tracking \
- --enable-fast-install \
- || return 1
- make || return 1
+ --enable-fast-install
+ make
}
package() {
- cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
}
dev() {