aboutsummaryrefslogtreecommitdiffstats
path: root/community/i3wm
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-03-11 00:45:51 +0000
committerSören Tempel <soeren+git@soeren-tempel.net>2018-03-11 14:41:47 +0100
commit7d7fe444d8df4803057ca828f12b9c278ecdbd4e (patch)
tree381add6c051d6d6be53643d1f99c87c47f2058a3 /community/i3wm
parent6e3c5dc150b97b72e9f5963d77edd5eb4c5a18e5 (diff)
downloadaports-7d7fe444d8df4803057ca828f12b9c278ecdbd4e.tar.bz2
aports-7d7fe444d8df4803057ca828f12b9c278ecdbd4e.tar.xz
community/i3wm: upgrade to 4.15, clarify license
Diffstat (limited to 'community/i3wm')
-rw-r--r--community/i3wm/APKBUILD25
-rw-r--r--community/i3wm/i3wm-musl-glob-tilde.patch (renamed from community/i3wm/musl.patch)0
2 files changed, 14 insertions, 11 deletions
diff --git a/community/i3wm/APKBUILD b/community/i3wm/APKBUILD
index 5b373a0033..09e4c93b25 100644
--- a/community/i3wm/APKBUILD
+++ b/community/i3wm/APKBUILD
@@ -1,30 +1,33 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=i3wm
-pkgver=4.14.1
+pkgver=4.15
pkgrel=0
-pkgdesc="A tiling window manager"
+pkgdesc="Improved dynamic tiling window manager"
url="http://i3wm.org"
arch="all"
-license="BSD"
+license="BSD-3-Clause"
makedepends="$depends_dev bison flex libxcb-dev xcb-util-cursor-dev
xcb-util-keysyms-dev xcb-util-wm-dev libev-dev pango-dev cairo-dev
yajl-dev startup-notification-dev pcre-dev libxkbcommon-dev xcb-util-xrm-dev"
subpackages="$pkgname-doc"
-source="http://i3wm.org/downloads/i3-${pkgver}.tar.bz2
- musl.patch"
-
-builddir="$srcdir/i3-$pkgver/"
+source="http://i3wm.org/downloads/i3-$pkgver.tar.bz2
+ i3wm-musl-glob-tilde.patch
+ "
+builddir="$srcdir/i3-$pkgver"
build() {
cd "$builddir"
- ./configure --disable-builddir --prefix="/usr" --sysconfdir="/etc"
+ ./configure \
+ --prefix="/usr" \
+ --disable-builddir \
+ --sysconfdir="/etc"
make
}
check() {
cd "$builddir"
- ./i3 --version
+ ./i3 --version > /dev/null
}
package() {
@@ -35,5 +38,5 @@ package() {
install -m644 man/*.1 "$pkgdir"/usr/share/man/man1/
}
-sha512sums="ef628af002947b40e1c88b0e872c6e93d4377a9674a120bd9adc3f323a38570b05124cd3047b5a26659e72070de2d00d83fb93186510c74ad8ddbf4f3df85472 i3-4.14.1.tar.bz2
-8ce7d00371c43b93dabbe0dadf9caf7c58a68f4a0079f5a9b9552c15c55bfa0df16d7e87a281595af2ac5254632ba28ccf82a467cea16159b41490f6f2910299 musl.patch"
+sha512sums="60ab61b7e380342126bea12fb4371f98fcf18f6435f79a9519d3f59cfabdb170634366036e1aa20c5592da0832b03140ad1f0c72bad3cfaace0b7c57ad01dfc4 i3-4.15.tar.bz2
+8ce7d00371c43b93dabbe0dadf9caf7c58a68f4a0079f5a9b9552c15c55bfa0df16d7e87a281595af2ac5254632ba28ccf82a467cea16159b41490f6f2910299 i3wm-musl-glob-tilde.patch"
diff --git a/community/i3wm/musl.patch b/community/i3wm/i3wm-musl-glob-tilde.patch
index 82ad6195b8..82ad6195b8 100644
--- a/community/i3wm/musl.patch
+++ b/community/i3wm/i3wm-musl-glob-tilde.patch