aboutsummaryrefslogtreecommitdiffstats
path: root/community/i3wm
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-11-11 16:04:30 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-11-11 16:07:19 +0200
commitc6996d4413af8f752ac125f58c8c473a77dae97e (patch)
tree4edf817e05a42db744943d84f5411ceef31b9191 /community/i3wm
parent7df0a26bb61b6a248365b028aa65819084a20d4b (diff)
downloadaports-c6996d4413af8f752ac125f58c8c473a77dae97e.tar.bz2
aports-c6996d4413af8f752ac125f58c8c473a77dae97e.tar.xz
community/i3wm: moved from testing
Diffstat (limited to 'community/i3wm')
-rw-r--r--community/i3wm/APKBUILD39
-rw-r--r--community/i3wm/musl.patch73
2 files changed, 112 insertions, 0 deletions
diff --git a/community/i3wm/APKBUILD b/community/i3wm/APKBUILD
new file mode 100644
index 0000000000..87959f9dcd
--- /dev/null
+++ b/community/i3wm/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=i3wm
+pkgver=4.12
+pkgrel=1
+pkgdesc="A tiling window manager"
+url="http://i3wm.org"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev bison flex libxcb-dev xcb-util-cursor-dev
+ xcb-util-keysyms-dev xcb-util-wm-dev libev-dev pango-dev cairo-dev
+ yajl-dev startup-notification-dev pcre-dev libxkbcommon-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://i3wm.org/downloads/i3-${pkgver}.tar.bz2
+ musl.patch"
+
+builddir="$srcdir/i3-$pkgver"
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir/" install || return 1
+
+ install -d "$pkgdir/usr/share/man/man1"
+ install -m644 man/*.1 "$pkgdir"/usr/share/man/man1/ || return 1
+}
+
+md5sums="308fc79ed252e1f3c8a093598e13e326 i3-4.12.tar.bz2
+aa998beb0b9a83d2910508768ac7faae musl.patch"
+sha256sums="e19e1ce08c2549cba83e083cc768d487202c41760d5c283f67752e791f1d78b4 i3-4.12.tar.bz2
+b7d084c53addc71fda13ccb8b3dcca2a32d9ca1590a28bf3be1a0c61870d3817 musl.patch"
+sha512sums="966f62dbd82c6c70d1344cc61f14f154f3f649ce1b5a5b5168f00f50d598582ef26f5bd5496ea62e13213e45b1c7043f6209c94fcbefe2947fec63284445c1f5 i3-4.12.tar.bz2
+8ce7d00371c43b93dabbe0dadf9caf7c58a68f4a0079f5a9b9552c15c55bfa0df16d7e87a281595af2ac5254632ba28ccf82a467cea16159b41490f6f2910299 musl.patch"
diff --git a/community/i3wm/musl.patch b/community/i3wm/musl.patch
new file mode 100644
index 0000000000..82ad6195b8
--- /dev/null
+++ b/community/i3wm/musl.patch
@@ -0,0 +1,73 @@
+diff -urp i3-4.11/i3bar/src/main.c i3-4.11.new/i3bar/src/main.c
+--- i3-4.11/i3bar/src/main.c 2015-09-30 07:55:10.000000000 +0100
++++ i3-4.11.new/i3bar/src/main.c 2016-02-08 20:03:41.777392482 +0000
+@@ -45,14 +45,20 @@ void debuglog(char *fmt, ...) {
+ *
+ */
+ char *expand_path(char *path) {
+- static glob_t globbuf;
+- if (glob(path, GLOB_NOCHECK | GLOB_TILDE, NULL, &globbuf) < 0) {
+- ELOG("glob() failed\n");
+- exit(EXIT_FAILURE);
++ char *home, *expanded;
++
++ if (strncmp(path, "~/", 2) == 0) {
++ home = getenv("HOME");
++ if (home != NULL) {
++ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
++ expanded = scalloc(strlen(home)+strlen(path), 1);
++ strcpy(expanded, home);
++ strcat(expanded, path+1);
++ return expanded;
++ }
+ }
+- char *result = sstrdup(globbuf.gl_pathc > 0 ? globbuf.gl_pathv[0] : path);
+- globfree(&globbuf);
+- return result;
++
++ return sstrdup(path);
+ }
+
+ void print_usage(char *elf_name) {
+diff -urp i3-4.11/libi3/resolve_tilde.c i3-4.11.new/libi3/resolve_tilde.c
+--- i3-4.11/libi3/resolve_tilde.c 2015-09-30 07:55:10.000000000 +0100
++++ i3-4.11.new/libi3/resolve_tilde.c 2016-02-08 20:03:47.849230953 +0000
+@@ -19,27 +19,18 @@
+ *
+ */
+ char *resolve_tilde(const char *path) {
+- static glob_t globbuf;
+- char *head, *tail, *result;
++ char *home, *expanded;
+
+- tail = strchr(path, '/');
+- head = sstrndup(path, tail ? (size_t)(tail - path) : strlen(path));
+-
+- int res = glob(head, GLOB_TILDE, NULL, &globbuf);
+- free(head);
+- /* no match, or many wildcard matches are bad */
+- if (res == GLOB_NOMATCH || globbuf.gl_pathc != 1)
+- result = sstrdup(path);
+- else if (res != 0) {
+- err(EXIT_FAILURE, "glob() failed");
+- } else {
+- head = globbuf.gl_pathv[0];
+- result = scalloc(strlen(head) + (tail ? strlen(tail) : 0) + 1, 1);
+- strncpy(result, head, strlen(head));
+- if (tail)
+- strncat(result, tail, strlen(tail));
++ if (strncmp(path, "~/", 2) == 0) {
++ home = getenv("HOME");
++ if (home != NULL) {
++ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
++ expanded = scalloc(strlen(home)+strlen(path), 1);
++ strcpy(expanded, home);
++ strcat(expanded, path+1);
++ return expanded;
++ }
+ }
+- globfree(&globbuf);
+
+- return result;
++ return sstrdup(path);
+ }