aboutsummaryrefslogtreecommitdiffstats
path: root/community/ibus
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-02-12 10:04:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-12 10:33:40 -0300
commit4cc657c815ec216c79f8a8ceac453f5c64d6f1e6 (patch)
tree4a67662790c7fe621002159ad4614f81fda66eb0 /community/ibus
parentc31b7112517013a67c220804c1be34ddbb941e88 (diff)
downloadaports-4cc657c815ec216c79f8a8ceac453f5c64d6f1e6.tar.bz2
aports-4cc657c815ec216c79f8a8ceac453f5c64d6f1e6.tar.xz
community/ibus: enable -emoji subpackage
Diffstat (limited to 'community/ibus')
-rw-r--r--community/ibus/APKBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/community/ibus/APKBUILD b/community/ibus/APKBUILD
index 8dfcc710d5..0893dc5d4a 100644
--- a/community/ibus/APKBUILD
+++ b/community/ibus/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=ibus
pkgver=1.5.21
-pkgrel=1
+pkgrel=2
pkgdesc="Next Generation Input Bus for Linux"
url="https://github.com/ibus/ibus/wiki"
arch="all !s390x" # librsvg
@@ -13,9 +13,9 @@ makedepends="
dconf-dev gtk+-dev gtk+3.0-dev libnotify-dev iso-codes-dev librsvg-dev
gobject-introspection-dev vala intltool qt5-qtbase
automake autoconf gnome-common gtk-doc wayland-dev wayland-protocols
- dbus-x11 unicode-character-database xz
+ dbus-x11 unicode-character-database xz unicode-emoji cldr-emoji-annotation
"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-emoji"
source="
$pkgname-$pkgver.tar.gz::https://github.com/ibus/ibus/archive/$pkgver.tar.gz
0001-Use-more-portable-call-to-mktemp.patch
@@ -37,7 +37,7 @@ build() {
--disable-memconf \
--enable-ui \
--disable-gtk-doc \
- --disable-emoji-dict \
+ --enable-emoji-dict \
--with-ucd-dir=/usr/share/unicode/
make
}
@@ -50,5 +50,13 @@ package() {
make DESTDIR="$pkgdir" install
}
+emoji() {
+ pkgdesc="$pkgdesc (emojis)"
+ depends="$pkgname unicode-emoji cldr-emoji-annotation"
+
+ mkdir -p "$subpkgdir"/usr/share/ibus
+ mv "$pkgdir"/usr/share/ibus/dicts "$subpkgdir"/usr/share/ibus
+}
+
sha512sums="39f5ffe0727af3254e060b82cc99a60126489271863272775e5b1d0e26f31d42d2f9a0cbfe1cb797854f2ae66d5b6c8cdf83bab800af8576b82250ec1e6fb33f ibus-1.5.21.tar.gz
1e2e62ce52becf75d794c403e8f21bb72e8406aacbdbc5189f62a3b7c54166c40da0032d3f3865f5a23d9d2c782f974b7bcc9ba5ce437d9eb435dd3db3ff0b06 0001-Use-more-portable-call-to-mktemp.patch"