aboutsummaryrefslogtreecommitdiffstats
path: root/community/iceauth
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 18:55:55 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:29:30 -0300
commit198d9417a8ef7f90a8ef03a172abf451d0993b5c (patch)
treeba4293936baa1d0f8cab90d9f6455137c3b13dd6 /community/iceauth
parent1f9301df23fae48c2b46edd8dd0c3cff0d705c23 (diff)
downloadaports-198d9417a8ef7f90a8ef03a172abf451d0993b5c.tar.bz2
aports-198d9417a8ef7f90a8ef03a172abf451d0993b5c.tar.xz
community/iceauth: move from main
Diffstat (limited to 'community/iceauth')
-rw-r--r--community/iceauth/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/iceauth/APKBUILD b/community/iceauth/APKBUILD
new file mode 100644
index 0000000000..dfd2d8b0e3
--- /dev/null
+++ b/community/iceauth/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=iceauth
+pkgver=1.0.8
+pkgrel=0
+pkgdesc="X.Org ICE authority file utility"
+url="http://xorg.freedesktop.org"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+depends=""
+makedepends="libice-dev util-macros"
+source="https://www.x.org/releases/individual/app/iceauth-$pkgver.tar.bz2"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="9d4520adf951b16a3e784349dbb70d5d8176b74b956f8adc63abf55d049745c113b03ccfa60a281fc39b487db3742302dc6287c9985ce83a0157bf4674df2af1 iceauth-1.0.8.tar.bz2"