aboutsummaryrefslogtreecommitdiffstats
path: root/community/icinga2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-05-13 16:22:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-13 16:22:31 +0000
commit0db7695c7e366c92f7943bce6d69b7a54a2f1dde (patch)
tree2eae42d1584470aa0137d2609796f474ff698fce /community/icinga2
parent7d29d197c6bfee7780355004d1d636fc1b64bd5d (diff)
downloadaports-0db7695c7e366c92f7943bce6d69b7a54a2f1dde.tar.bz2
aports-0db7695c7e366c92f7943bce6d69b7a54a2f1dde.tar.xz
community/icinga2: force build against system yajl
Diffstat (limited to 'community/icinga2')
-rw-r--r--community/icinga2/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/icinga2/APKBUILD b/community/icinga2/APKBUILD
index 9a0703e270..cb654637da 100644
--- a/community/icinga2/APKBUILD
+++ b/community/icinga2/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=icinga2
pkgver=2.4.7
-pkgrel=1
+pkgrel=2
pkgdesc="An open source host, service and network monitoring program"
url="http://www.icinga.org"
arch="all"
license="GPL"
depends="monitoring-plugins"
depends_dev=""
-makedepends="$depends_dev cmake bison flex boost-dev yajl
+makedepends="$depends_dev cmake bison flex boost-dev yajl-dev
postgresql-dev mariadb-dev openssl-dev"
install="$pkgname.pre-install $pkgname.post-install"
pkgusers="icinga"
@@ -27,6 +27,7 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ rm -r third-party/yajl
mkdir -p build
}
@@ -41,12 +42,12 @@ build() {
-DCMAKE_INSTALL_LOCALSTATEDIR=/var \
-DICINGA2_SYSCONFIGFILE=/etc/icinga2 \
-DICINGA2_PLUGINDIR=/usr/lib/monitoring-plugins \
- -DICINGA2_USER=$pkgusers \
+ -DICINGA2_USER=$pkgusers \
-DICINGA2_GROUP=${pkggroups}cmd \
-DICINGA2_COMMAND_USER=$pkgusers \
-DICINGA2_COMMAND_GROUP=${pkggroups}cmd \
-DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=no
- make || return 1
+ make || return 1
}
package() {