aboutsummaryrefslogtreecommitdiffstats
path: root/community/icinga2
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-02-04 10:10:21 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-02-04 10:10:32 +0000
commit384ec2b7e8c0240ad27ddaffbdc957e39d2dad84 (patch)
treefc1c1981b933c9af45ab18d8d0eb66007ee959ae /community/icinga2
parent853ed4576de4a23cf6f6e0bce95903c1ced82bd8 (diff)
downloadaports-384ec2b7e8c0240ad27ddaffbdc957e39d2dad84.tar.bz2
aports-384ec2b7e8c0240ad27ddaffbdc957e39d2dad84.tar.xz
community/icinga2: fixed how to figure out the correct version
Diffstat (limited to 'community/icinga2')
-rw-r--r--community/icinga2/APKBUILD31
1 files changed, 16 insertions, 15 deletions
diff --git a/community/icinga2/APKBUILD b/community/icinga2/APKBUILD
index 0ffd70844f..417789d855 100644
--- a/community/icinga2/APKBUILD
+++ b/community/icinga2/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=icinga2
pkgver=2.6.1
-pkgrel=0
+pkgrel=1
pkgdesc="An open source host, service and network monitoring program"
url="http://www.icinga.org"
arch="all !armhf"
@@ -19,7 +19,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/$pkgname/archive/v$pk
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- local i
cd "$builddir"
rm -r third-party/yajl
mkdir -p build
@@ -28,19 +27,21 @@ prepare() {
build() {
cd "$builddir"/build
cmake "$srcdir/$pkgname-$pkgver" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_SYSCONFDIR=/etc \
- -DICINGA2_RUNDIR=/run \
- -DCMAKE_INSTALL_SBINDIR=/usr/sbin \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib \
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
- -DICINGA2_SYSCONFIGFILE=/etc/icinga2 \
- -DICINGA2_PLUGINDIR=/usr/lib/monitoring-plugins \
- -DICINGA2_USER=$pkgusers \
- -DICINGA2_GROUP=${pkggroups}cmd \
- -DICINGA2_COMMAND_USER=$pkgusers \
- -DICINGA2_COMMAND_GROUP=${pkggroups}cmd \
- -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=no
+ -DCMAKE_BUILD_TYPE=None \
+ -DICINGA2_GIT_VERSION_INFO=OFF \
+ -DICINGA2_UNITY_BUILD=FALSE \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DICINGA2_RUNDIR=/run \
+ -DCMAKE_INSTALL_SBINDIR=/usr/sbin \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
+ -DICINGA2_SYSCONFIGFILE=/etc/icinga2 \
+ -DICINGA2_PLUGINDIR=/usr/lib/monitoring-plugins \
+ -DICINGA2_USER=$pkgusers \
+ -DICINGA2_GROUP=${pkggroups}cmd \
+ -DICINGA2_COMMAND_GROUP=${pkggroups}cmd \
+ -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=no
make || return 1
}