aboutsummaryrefslogtreecommitdiffstats
path: root/community/icingaweb2
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-05-04 10:01:15 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-05-04 10:01:15 +0000
commit8aee06c26899a70bd8c2597cca85a46e311c9fac (patch)
tree9c7573e19963fe92a6dee01c10a3d23ab2e2af78 /community/icingaweb2
parent21af85c66d353942adbd3e5307bea4121bb9a941 (diff)
downloadaports-8aee06c26899a70bd8c2597cca85a46e311c9fac.tar.bz2
aports-8aee06c26899a70bd8c2597cca85a46e311c9fac.tar.xz
community/icingaweb2: use php7, disable check()
PHP7 appears to be supported since release 2.2.0 https://github.com/Icinga/icingaweb2/issues/2027
Diffstat (limited to 'community/icingaweb2')
-rw-r--r--community/icingaweb2/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/community/icingaweb2/APKBUILD b/community/icingaweb2/APKBUILD
index 57720cb1e0..059dc1cb81 100644
--- a/community/icingaweb2/APKBUILD
+++ b/community/icingaweb2/APKBUILD
@@ -2,23 +2,21 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=icingaweb2
pkgver=2.4.1
-pkgrel=2
+pkgrel=3
pkgdesc="Web Interface for Icinga2"
url="http://www.icinga.org"
arch="noarch !armhf !ppc64le"
license="GPL"
-_php=php5
+_php=php7
depends="icinga2 $_php ${_php}-gd ${_php}-ldap ${_php}-intl ${_php}-pgsql
- ${_php}-mysql ${_php}-gettext ${_php}-ctype ${_php}-openssl ${_php}-sockets
+ ${_php}-mysqlnd ${_php}-gettext ${_php}-ctype ${_php}-openssl ${_php}-sockets
${_php}-json ${_php}-dom ${_php}-imagick ${_php}-pdo_mysql
${_php}-pdo_pgsql"
-depends_dev=""
-makedepends="$depends_dev"
pkggroups="icingaweb2"
+options="!check"
install="$pkgname.pre-install $pkgname.post-install"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/${pkgname}/archive/v$pkgver.tar.gz"
-
builddir="$srcdir"/$pkgname-$pkgver
build() {
@@ -46,7 +44,7 @@ You need to add to $pkgroups group the owner of the user of your webserver
For nginx, as example:
# adduser nginx $pkgusers
or
- #adduser nobody $pkgusers
+ #adduser nobody $pkgusers
For Apache:
# adduser apache $pkgusers