aboutsummaryrefslogtreecommitdiffstats
path: root/community/imagemagick/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-15 22:17:00 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-16 02:04:19 -0300
commit8ae0dbf985732b4f4b66a5ae1a0cf3e793c4a589 (patch)
tree725f4388a2c7538d0961973edfcfcc085ff504a5 /community/imagemagick/APKBUILD
parent3964fe8876b4b7c968d815034101e6d3c280d695 (diff)
downloadaports-8ae0dbf985732b4f4b66a5ae1a0cf3e793c4a589.tar.bz2
aports-8ae0dbf985732b4f4b66a5ae1a0cf3e793c4a589.tar.xz
community/imagemagick: enable static libraries
fixes #10782
Diffstat (limited to 'community/imagemagick/APKBUILD')
-rw-r--r--community/imagemagick/APKBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/community/imagemagick/APKBUILD b/community/imagemagick/APKBUILD
index fcc7d3515e..1a39b77b4a 100644
--- a/community/imagemagick/APKBUILD
+++ b/community/imagemagick/APKBUILD
@@ -4,7 +4,7 @@
pkgname=imagemagick
_pkgname=ImageMagick
pkgver=7.0.10.0
-pkgrel=0
+pkgrel=1
_pkgver=${pkgver%.*}-${pkgver##*.}
_abiver=7
pkgdesc="Collection of tools and libraries for many image formats"
@@ -23,7 +23,15 @@ case "$CARCH" in
esac
checkdepends="freetype fontconfig ghostscript ghostscript-fonts lcms2 graphviz"
-subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx $pkgname-libs $pkgname-perlmagick:_perlmagick $pkgname-perlmagick-doc:_perlmagick_doc"
+subpackages="
+ $pkgname-doc
+ $pkgname-static
+ $pkgname-dev
+ $pkgname-c++:_cxx
+ $pkgname-libs
+ $pkgname-perlmagick:_perlmagick
+ $pkgname-perlmagick-doc:_perlmagick_doc
+ "
source="$_pkgname-$_pkgver.tar.gz::https://github.com/ImageMagick/ImageMagick/archive/$_pkgver.tar.gz
disable-avaraging-tests.patch"
builddir="$srcdir/$_pkgname-$_pkgver"
@@ -100,7 +108,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --disable-static \
+ --enable-static \
--disable-openmp \
--with-threads \
--with-x \