aboutsummaryrefslogtreecommitdiffstats
path: root/community/inkscape
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-28 08:42:45 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-28 08:42:54 +0000
commita2ee9705c3d9359502fe52be3aa4603dcaf1398f (patch)
tree78088cbcce000bcbf9b4ffaa61e3077dba865d9b /community/inkscape
parent105a637d5ba72c78ad6d0ee5a3f08800d2a22680 (diff)
downloadaports-a2ee9705c3d9359502fe52be3aa4603dcaf1398f.tar.bz2
aports-a2ee9705c3d9359502fe52be3aa4603dcaf1398f.tar.xz
community/inkscape: fix mdepends, add check(), modernize APKBUILD
Diffstat (limited to 'community/inkscape')
-rw-r--r--community/inkscape/APKBUILD29
1 files changed, 12 insertions, 17 deletions
diff --git a/community/inkscape/APKBUILD b/community/inkscape/APKBUILD
index db64e0aca0..b2ca0a8725 100644
--- a/community/inkscape/APKBUILD
+++ b/community/inkscape/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=inkscape
pkgver=0.91
-pkgrel=15
+pkgrel=16
pkgdesc="A vector-based drawing program - svg compliant"
url="http://inkscape.sourceforge.net/"
arch="all"
@@ -20,25 +20,19 @@ makedepends="
libxslt-dev
poppler-dev
popt-dev
- py-xml
tar
"
depends="desktop-file-utils"
-install=
+checkdepends="bash"
subpackages="$pkgname-doc $pkgname-lang $pkgname-view"
source="https://launchpad.net/inkscape/$pkgver.x/$pkgver/+download/inkscape-$pkgver.tar.bz2
fix-crash.patch
"
-
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg "$i"; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ cd "$builddir"
+ default_prepare
#aclocal -I m4 && autoconf && automake -a && autoheader
# we enable fortify source by default so to silence warnings we
# remove it from cmdline
@@ -46,7 +40,7 @@ prepare() {
}
build() {
- cd "$_builddir"
+ cd "$builddir"
CXXFLAGS="$CXXFLAGS -std=c++11" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -60,8 +54,13 @@ build() {
make || return 1
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
@@ -78,9 +77,5 @@ doc() {
"$pkgdir"/usr/share/inkscape/tutorials \
"$subpkgdir"/usr/share/inkscape
}
-md5sums="278dfa4514adcde23546370ec2c84581 inkscape-0.91.tar.bz2
-e2cfb1380608e08a56d20ced3dacfea0 fix-crash.patch"
-sha256sums="4d901f8a9e1924404e797ad23b8b0c495a9d155448816d95a55974314e1f141b inkscape-0.91.tar.bz2
-83feb2e58445c034cc13bd09350ff9cd08cee6421a13d8debecdfd35d62659e5 fix-crash.patch"
sha512sums="3778ef7d4a1c759a7afc093e55eefb69a78dcb60332655cc8ab8c481f54a3e6550df6070178390eb08588245531906b8bef33301f0765a4d28d6c7506fcf3bc7 inkscape-0.91.tar.bz2
d91a72c4363a5cd736593478580ef6175f6a7db0b601bf3a4af5c97c4bd1c295feb9e31365d5185be4d9cf4fddd642821a43337d914d6c257bef6c450d7ef70a fix-crash.patch"