aboutsummaryrefslogtreecommitdiffstats
path: root/community/iouyap
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 12:30:54 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 13:00:04 +0000
commitfb6ca37bb5d4f8b9c19ae383286ddd4b55eef611 (patch)
tree4963c0da458e47bc6b779c89f4b43a284e955725 /community/iouyap
parentd6d38dc6bf326fe55513628786326191caa5922e (diff)
downloadaports-fb6ca37bb5d4f8b9c19ae383286ddd4b55eef611.tar.bz2
aports-fb6ca37bb5d4f8b9c19ae383286ddd4b55eef611.tar.xz
community/iouyap: moved from testing
Diffstat (limited to 'community/iouyap')
-rw-r--r--community/iouyap/APKBUILD35
-rw-r--r--community/iouyap/musl-fixes.patch39
2 files changed, 74 insertions, 0 deletions
diff --git a/community/iouyap/APKBUILD b/community/iouyap/APKBUILD
new file mode 100644
index 0000000000..63e6a6d793
--- /dev/null
+++ b/community/iouyap/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=iouyap
+pkgver=0.97
+pkgrel=0
+pkgdesc="Bridge IOU to UDP, TAP and Ethernet."
+url="https://github.com/GNS3/iouyap"
+arch="all"
+license="GPL3"
+depends=""
+depends_dev=""
+makedepends="$depends_dev linux-headers bison flex bsd-compat-headers"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/GNS3/$pkgname/archive/v$pkgver.tar.gz
+ musl-fixes.patch"
+
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums="d874e11fd32c3348c1d5f92d60274f72 iouyap-0.97.tar.gz
+22b79954e6520b01c2b3ed77d41ea49d musl-fixes.patch"
+sha256sums="181850a4ce73a4d4035f9eb39b2656ae31d360f18b577ee65f5149132da3eccf iouyap-0.97.tar.gz
+4849669e70974e563ca728c047dc560ea50696c1645a8139e5bc5d3192ef2b21 musl-fixes.patch"
+sha512sums="c6b3779bb1a0a004085796bb72cc9824ef3ef04db70cef13a12a2f33676fca11d721c1dcd81a4caff67ce56511624f293c89579705434a24332f672a8dfa2d33 iouyap-0.97.tar.gz
+311a7e330baa5cb762390e941d4f7c48385feef0e6cddb0252307a16fa69d5515408dcfe2b4f9a8523a05b5c9edd79df4509d51a8ac0163959a6a4f9e61f6e4a musl-fixes.patch"
diff --git a/community/iouyap/musl-fixes.patch b/community/iouyap/musl-fixes.patch
new file mode 100644
index 0000000000..e71ce2dcf7
--- /dev/null
+++ b/community/iouyap/musl-fixes.patch
@@ -0,0 +1,39 @@
+diff --git a/netmap.c b/netmap.c
+index bbdf257..69b5e47 100644
+--- a/netmap.c
++++ b/netmap.c
+@@ -28,6 +28,7 @@
+ #include <string.h>
+ #include <netdb.h>
+ #include <sys/socket.h>
++#include <sys/types.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+
+diff --git a/iouyap.c b/iouyap.c
+index 555b908..26a33ef 100644
+--- a/iouyap.c
++++ b/iouyap.c
+@@ -35,7 +35,9 @@
+ #include <linux/if_tun.h>
+ #include <arpa/inet.h>
+ #include <netpacket/packet.h>
++#if HAVE_NETINET_IF_ETHER_H && !HAVE_LINUX_IF_TUN_H
+ #include <net/ethernet.h>
++#endif
+ #include <netdb.h>
+ #include <net/if_arp.h>
+ #include <linux/rtnetlink.h>
+
+diff --git a/iouyap.h b/iouyap.h
+index c4088fb..698bcd5 100644
+--- a/iouyap.h
++++ b/iouyap.h
+@@ -24,6 +24,7 @@
+ #include <netinet/in.h>
+ #include <errno.h>
+ #include <sys/un.h>
++#include <sys/types.h>
+
+ #define NAME "iouyap"
+ #define VERSION "0.97.0"