aboutsummaryrefslogtreecommitdiffstats
path: root/community/java-jna/disable-Werror.patch
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2018-12-21 16:01:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-12-21 18:07:27 +0000
commit8c72e8e6e32a0660fce22117dd192980be8e7e57 (patch)
treee5aff31f1edca2d10d2bbd933dabe18fd6634b2a /community/java-jna/disable-Werror.patch
parentee04f96c6c86d0ab74c4a1cbffa55ad7e36f4bf5 (diff)
downloadaports-8c72e8e6e32a0660fce22117dd192980be8e7e57.tar.bz2
aports-8c72e8e6e32a0660fce22117dd192980be8e7e57.tar.xz
community/java-jna: fix build break by disabling Werror flag
Diffstat (limited to 'community/java-jna/disable-Werror.patch')
-rw-r--r--community/java-jna/disable-Werror.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/community/java-jna/disable-Werror.patch b/community/java-jna/disable-Werror.patch
new file mode 100644
index 0000000000..70f42bc5ff
--- /dev/null
+++ b/community/java-jna/disable-Werror.patch
@@ -0,0 +1,11 @@
+--- a/native/Makefile
++++ b/native/Makefile
+@@ -336,7 +336,7 @@
+ ifeq ($(CC),gcc)
+ GCC_MAJOR_VERSION = $(shell gcc -dumpversion | cut -f 1 -d '.')
+ ifneq ($(GCC_MAJOR_VERSION),4)
+- LOC_CC_OPTS=-Wno-unknown-warning-option -Werror -Wno-clobbered -Wno-unused-variable
++ LOC_CC_OPTS=-Wno-unknown-warning-option -Wno-clobbered -Wno-unused-variable
+ endif
+ else
+ LOC_CC_OPTS=-Wno-unknown-warning-option -Werror -Wno-clobbered -Wno-unused-variable