aboutsummaryrefslogtreecommitdiffstats
path: root/community/john/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-10-09 16:40:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-10-09 16:41:28 +0000
commit2da300eda5252ac1304a15933c2030f42ddbf610 (patch)
tree258e66dce8f56fc0b04741159b13dfa9a86faff2 /community/john/APKBUILD
parent667cbe30d8c18b8e0278bdd0ea499fc07d22ca59 (diff)
downloadaports-2da300eda5252ac1304a15933c2030f42ddbf610.tar.bz2
aports-2da300eda5252ac1304a15933c2030f42ddbf610.tar.xz
community/john: whitespace damage and linter fixes
Diffstat (limited to 'community/john/APKBUILD')
-rw-r--r--community/john/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/community/john/APKBUILD b/community/john/APKBUILD
index cfecbddd4f..bd137aacdb 100644
--- a/community/john/APKBUILD
+++ b/community/john/APKBUILD
@@ -14,12 +14,12 @@ options="!strip !check" # needs config files in /usr which are not there during
makedepends="libpcap-dev openssl-dev gmp-dev yasm-dev zlib-dev"
subpackages="$pkgname-doc"
-source="https://www.openwall.com/john/k/$pkgname-$pkgver-$_pkgrel.tar.xz"
+source="https://www.openwall.com/john/k/john-$pkgver-$_pkgrel.tar.xz"
builddir="$srcdir"/$pkgname-$pkgver-$_pkgrel
build() {
cd "$builddir"/src
- ./configure --prefix=/usr
+ ./configure --prefix=/usr
make
}
@@ -30,17 +30,17 @@ check() {
package() {
cd "$builddir/src"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install
cd "$builddir"
mkdir -p "$pkgdir"/usr/bin
mkdir -p "$pkgdir"/usr/share/doc/$pkgname
mkdir -p "$pkgdir"/usr/share/$pkgname/rules
- mv doc/extras "$pkgdir"/usr/share/doc/$pkgname
+ mv doc/extras "$pkgdir"/usr/share/doc/$pkgname
install -Dm644 doc/* "$pkgdir"/usr/share/doc/$pkgname
- install -Dm644 run/rules/* "$pkgdir"/usr/share/$pkgname/rules
- install -Dm644 run/*.conf "$pkgdir"/usr/share/$pkgname/
- install -Dm644 run/*.chr "$pkgdir"/usr/share/$pkgname/
+ install -Dm644 run/rules/* "$pkgdir"/usr/share/$pkgname/rules
+ install -Dm644 run/*.conf "$pkgdir"/usr/share/$pkgname/
+ install -Dm644 run/*.chr "$pkgdir"/usr/share/$pkgname/
install -Dm644 doc/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
rm "$pkgdir"/usr/share/doc/$pkgname/LICENSE*