aboutsummaryrefslogtreecommitdiffstats
path: root/community/julia
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-10-19 01:48:38 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-10-19 01:48:38 +0000
commit03d675209199a95b92542ddd83a777b81dfd5261 (patch)
tree9b43df52cd623ff8e98bb46ac000dfd4b40cd7b2 /community/julia
parent70ac78a1493c3d1f8231228a732e826f01e32b03 (diff)
downloadaports-03d675209199a95b92542ddd83a777b81dfd5261.tar.bz2
aports-03d675209199a95b92542ddd83a777b81dfd5261.tar.xz
community/julia: fix build on x86_64
Diffstat (limited to 'community/julia')
-rw-r--r--community/julia/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/julia/APKBUILD b/community/julia/APKBUILD
index d0b9563322..973a811f27 100644
--- a/community/julia/APKBUILD
+++ b/community/julia/APKBUILD
@@ -10,7 +10,7 @@ pkgrel=0
pkgdesc="A high-level, high-performance dynamic language for technical computing"
url="http://julialang.org"
# x86: no libunwind package
-arch=""
+arch="x86_64"
license="MIT"
depends="arpack
dsfmt
@@ -52,6 +52,7 @@ makedepends="$depends_dev
subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg"
source="https://github.com/JuliaLang/julia/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
libuv-$_libuv_ver.tar.gz::https://api.github.com/repos/JuliaLang/libuv/tarball/$_libuv_ver
+ http://www.unicode.org/Public/9.0.0/ucd/UnicodeData.txt
find-syslibs
0001-hardened.patch
0002-verbose-build.patch
@@ -73,6 +74,9 @@ prepare() {
mkdir deps/srccache
cp "$srcdir"/libuv-$_libuv_ver.tar.gz deps/srccache
+ # Prevent fetching of unicode data.
+ cp "$srcdir"/UnicodeData.txt doc/UnicodeData.txt
+
# Prevent fetching of bundled stuff in the build and package phase.
cat > deps/tools/jldownload <<-'EOF'
#!/bin/sh
@@ -169,6 +173,7 @@ dbg() {
sha512sums="da21b35eb2c682c0fb8720974a76759c51fe993f10e6af5ca4864fc7f0bb6c90d880b706eb798476c7228bae2db19ff0825add6a2abde2961f16a93a3050cb69 julia-0.6.0.tar.gz
4bf9c8b16617691b70ea43c667ecc575d2a06b3d0c347b949d10360c012138585a13ecea5e18de81b1585a96cf7734b7cc3d6072490898f1d5531c702cf5afab libuv-52d72a52cc7ccd570929990f010ed16e2ec604c8.tar.gz
+43eaf66d9cb3748012b2dfd77da1b41f667c5c7602a56bea8186b796b215bde82d555d79ab053378c2222521396354dcce5cf23a78fa3b1456062c47771c8433 UnicodeData.txt
0283c7b0ff7dd99ae79f6ddac63513ce7d58ba31de506a3fee07af9b8882ddc275d0f9cb002381ba1e304bcacf252612fa16b21b85667422477e6b945b725899 find-syslibs
f812b05b7712975eaef0bf071dd2c1cd0b21c68b18d6a513878bb8fe877bfcadf9f4b9dd8cd27b6809378de5b250a010301e7a90169677d155ad2ba377e8b428 0001-hardened.patch
52bbaff51c7d0299e875294b43e23773bcdbe1bc7d02b670814d051bb4f1224bba507182944dc739adb07acd10d3d7f5a0ac7c270c28d3a760d36d90520a2f16 0002-verbose-build.patch