aboutsummaryrefslogtreecommitdiffstats
path: root/community/julia
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-19 02:50:32 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-19 02:50:32 +0200
commit243ef3763a7a93f1ab783afbc847f7783f539f4c (patch)
tree9f8d8a66017eb952a7d5a940287c79055a5811c8 /community/julia
parent89182e0a43c4e4beac1bb5d9f87d267bc62eed6a (diff)
downloadaports-243ef3763a7a93f1ab783afbc847f7783f539f4c.tar.bz2
aports-243ef3763a7a93f1ab783afbc847f7783f539f4c.tar.xz
Revert "community/julia: upgrade to 0.6.0"
This reverts commit 89182e0a43c4e4beac1bb5d9f87d267bc62eed6a. Sorry, I somehow messed up merging...
Diffstat (limited to 'community/julia')
-rw-r--r--community/julia/0001-hardened.patch18
-rw-r--r--community/julia/0002-verbose-build.patch15
-rw-r--r--community/julia/0003-no-clean-docs.patch6
-rw-r--r--community/julia/0004-remove-sysctl.h.patch33
-rw-r--r--community/julia/APKBUILD22
-rw-r--r--community/julia/fix-or-disable-broken-tests.patch32
-rw-r--r--community/julia/test-disable-tests-using-fake_pty.patch36
-rw-r--r--community/julia/test-libgit2-skip-SSL_CERT_FILE.patch27
-rw-r--r--community/julia/test-repl-disable-22176-20482.patch32
9 files changed, 75 insertions, 146 deletions
diff --git a/community/julia/0001-hardened.patch b/community/julia/0001-hardened.patch
index 33b3781da8..2984356c7b 100644
--- a/community/julia/0001-hardened.patch
+++ b/community/julia/0001-hardened.patch
@@ -1,31 +1,29 @@
From: Jakub Jirutka <jakub@jirutka.cz>
Date: Sun, 05 Jun 2016 14:11:00 +0200
-Last-Updated: Thu, 19 Oct 2017 01:04:00 +0200
Subject: [PATCH] Disable PaX memory protection for julia binary
--- a/Makefile
+++ b/Makefile
-@@ -111,8 +111,14 @@
+@@ -71,7 +71,13 @@
julia-sysimg-debug : julia-inference julia-ui-debug
- @$(MAKE) $(QUIET_MAKE) -C $(BUILDROOT) $(build_private_libdir)/sys-debug$(CPUID_TAG).$(SHLIB_EXT) JULIA_BUILD_MODE=debug
+ @$(MAKE) $(QUIET_MAKE) $(build_private_libdir)/sys-debug.$(SHLIB_EXT) JULIA_BUILD_MODE=debug
-julia-debug julia-release : julia-% : julia-ui-% julia-sysimg-% julia-symlink julia-libccalltest
+julia-pax-release : julia-ui-release
+ paxmark m $(JULIA_EXECUTABLE_release)
-
++
+julia-pax-debug : julia-ui-debug
+ paxmark m $(JULIA_EXECUTABLE_debug)
+
+julia-debug julia-release : julia-% : julia-ui-% julia-pax-% julia-sysimg-% julia-symlink julia-libccalltest
-+
+
debug release : % : julia-%
- docs: julia-sysimg-$(JULIA_BUILD_MODE)
-@@ -551,7 +557,7 @@
+@@ -527,7 +533,7 @@
test testall testall1 test clean distcleanall cleanall clean-* \
run-julia run-julia-debug run-julia-release run \
install binary-dist light-source-dist.tmp light-source-dist \
-- dist full-source-dist source-dist examples
-+ dist full-source-dist source-dist examples julia-pax-release julia-pax-debug
+- dist full-source-dist source-dist
++ dist full-source-dist source-dist julia-pax-release julia-pax-debug
test: check-whitespace $(JULIA_BUILD_MODE)
- @$(MAKE) $(QUIET_MAKE) -C $(BUILDROOT)/test default JULIA_BUILD_MODE=$(JULIA_BUILD_MODE)
+ @$(MAKE) $(QUIET_MAKE) -C test default JULIA_BUILD_MODE=$(JULIA_BUILD_MODE)
diff --git a/community/julia/0002-verbose-build.patch b/community/julia/0002-verbose-build.patch
index 51651aa172..c13f93fead 100644
--- a/community/julia/0002-verbose-build.patch
+++ b/community/julia/0002-verbose-build.patch
@@ -1,18 +1,17 @@
Description: Ensure that build is verbose
Author: Sébastien Villemot <sebastien@debian.org>
Author: Shiz <hi@shiz.me>
-Author: Jakub Jirutka <jakub@jirutka.cz>
Forwarded: not-needed
-Last-Updated: 2017-10-19
+Last-Update: 2017-05-19
---
--- a/deps/libuv.mk
+++ b/deps/libuv.mk
-@@ -30,7 +30,7 @@
+@@ -33,7 +33,7 @@
touch -c $(SRCDIR)/srccache/$(LIBUV_SRC_DIR)/configure
mkdir -p $(dir $@)
cd $(dir $@) && \
-- $(dir $<)/configure --with-pic $(CONFIGURE_COMMON) $(UV_FLAGS)
-+ $(dir $<)/configure --with-pic $(CONFIGURE_COMMON) $(UV_FLAGS) --disable-silent-rules
- echo 1 > $@
-
- $(BUILDDIR)/$(LIBUV_SRC_DIR)/build-compiled: $(BUILDDIR)/$(LIBUV_SRC_DIR)/build-configured
+- $< --with-pic $(CONFIGURE_COMMON) $(UV_FLAGS)
++ $< --with-pic $(CONFIGURE_COMMON) $(UV_FLAGS) --disable-silent-rules
+ touch -c $@
+ $(UV_SRC_TARGET): $(BUILDDIR)/$(LIBUV_SRC_DIR)/config.status
+ $(MAKE) -C $(dir $<) $(UV_MFLAGS)
diff --git a/community/julia/0003-no-clean-docs.patch b/community/julia/0003-no-clean-docs.patch
index 0be74175cc..89bb0f8fae 100644
--- a/community/julia/0003-no-clean-docs.patch
+++ b/community/julia/0003-no-clean-docs.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -526,7 +526,6 @@
+@@ -540,7 +540,6 @@
clean: | $(CLEAN_TARGETS)
@-$(MAKE) -C $(BUILDROOT)/base clean
@@ -8,11 +8,11 @@
@-$(MAKE) -C $(BUILDROOT)/src clean
@-$(MAKE) -C $(BUILDROOT)/ui clean
@-$(MAKE) -C $(BUILDROOT)/test clean
-@@ -548,7 +547,6 @@
+@@ -564,7 +563,6 @@
distcleanall: cleanall
@-$(MAKE) -C $(BUILDROOT)/deps distcleanall
- @-$(MAKE) -C $(BUILDROOT)/doc cleanall
+ -rm -fr $(build_prefix) $(build_staging)
.PHONY: default debug release check-whitespace release-candidate \
- julia-debug julia-release julia-deps \
diff --git a/community/julia/0004-remove-sysctl.h.patch b/community/julia/0004-remove-sysctl.h.patch
new file mode 100644
index 0000000000..42c71cb893
--- /dev/null
+++ b/community/julia/0004-remove-sysctl.h.patch
@@ -0,0 +1,33 @@
+From 6f09a6de41e7e35779e0755d9e52a4bf79424109 Mon Sep 17 00:00:00 2001
+From: albap <albapompeo@gmail.com>
+Date: Sun, 31 Jan 2016 10:50:02 -0200
+Subject: [PATCH] Remove nonstandard header sys/sysctl.h
+
+This header prevents me from building Julia on musl libc.
+
+```
+/home/alba/julia/src/sys.c:16:24: fatal error: sys/sysctl.h: No such file or directory
+compilation terminated.
+Makefile:94: recipe for target 'sys.o' failed
+make[1]: *** [sys.o] Error 1
+```
+
+If I remove it from julia/src/sys.c then it works.
+
+Why is sys/sysctl.h needed in first place? I cannot find it in POSIX.
+---
+ src/sys.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/sys.c b/src/sys.c
+index 9a48871..89069a9 100644
+--- a/src/sys.c
++++ b/src/sys.c
+@@ -13,7 +13,6 @@
+ #ifdef _OS_WINDOWS_
+ #include <psapi.h>
+ #else
+-#include <sys/sysctl.h>
+ #include <sys/wait.h>
+ #include <sys/ptrace.h>
+ #include <unistd.h>
diff --git a/community/julia/APKBUILD b/community/julia/APKBUILD
index 2b87abadec..a6ebd071f7 100644
--- a/community/julia/APKBUILD
+++ b/community/julia/APKBUILD
@@ -25,7 +25,6 @@ depends="arpack
suitesparse>=4.1
"
depends_dev="arpack-dev
- curl-dev
dsfmt-dev
fftw-dev
gmp-dev
@@ -56,12 +55,10 @@ source="https://github.com/JuliaLang/julia/releases/download/v$pkgver/$pkgname-$
0001-hardened.patch
0002-verbose-build.patch
0003-no-clean-docs.patch
+ 0004-remove-sysctl.h.patch
0005-fix-rpath-issues.patch
0008-ldconfig-compat.patch
fix-or-disable-broken-tests.patch
- test-disable-tests-using-fake_pty.patch
- test-libgit2-skip-SSL_CERT_FILE.patch
- test-repl-disable-22176-20482.patch
"
builddir="$srcdir/$pkgname-$pkgver"
ldpath="/usr/lib/julia"
@@ -109,7 +106,6 @@ prepare() {
USE_SYSTEM_SUITESPARSE=1
USE_SYSTEM_LIBUV=0
USE_SYSTEM_UTF8PROC=1
- USE_SYSTEM_CURL=1
USE_SYSTEM_LIBGIT2=1
USE_SYSTEM_PATCHELF=1
USE_LLVM_SHLIB=1
@@ -167,15 +163,13 @@ dbg() {
mv "$pkgdir"/usr/lib/julia/*-debug.* "$subpkgdir"/usr/lib/julia/
}
-sha512sums="da21b35eb2c682c0fb8720974a76759c51fe993f10e6af5ca4864fc7f0bb6c90d880b706eb798476c7228bae2db19ff0825add6a2abde2961f16a93a3050cb69 julia-0.6.0.tar.gz
-4bf9c8b16617691b70ea43c667ecc575d2a06b3d0c347b949d10360c012138585a13ecea5e18de81b1585a96cf7734b7cc3d6072490898f1d5531c702cf5afab libuv-52d72a52cc7ccd570929990f010ed16e2ec604c8.tar.gz
+sha512sums="70b3e23c7297d86268c2d32b0c19976dc6f9512bd41c5e9f621b1b9a082ed25ee85cf5f11f3e5acfc623b3a13fa88d245eb2609bad01935d86d90b502d068353 julia-0.5.2.tar.gz
+c53513a5aea84405bf302b084a23f24f54148aac90a2bd666219ce14879723baab959942934d0d801a4572fffd07e60a7d574ade8d7eb57b6da8216063c20a48 libuv-8d5131b6c1595920dd30644cd1435b4f344b46c8.tar.gz
0283c7b0ff7dd99ae79f6ddac63513ce7d58ba31de506a3fee07af9b8882ddc275d0f9cb002381ba1e304bcacf252612fa16b21b85667422477e6b945b725899 find-syslibs
-f812b05b7712975eaef0bf071dd2c1cd0b21c68b18d6a513878bb8fe877bfcadf9f4b9dd8cd27b6809378de5b250a010301e7a90169677d155ad2ba377e8b428 0001-hardened.patch
-52bbaff51c7d0299e875294b43e23773bcdbe1bc7d02b670814d051bb4f1224bba507182944dc739adb07acd10d3d7f5a0ac7c270c28d3a760d36d90520a2f16 0002-verbose-build.patch
-04ab09428c299ca1cc7f162d2344763d9b9136c209a6718df62689f421b4925af20a7b739513965dcbdcbf191577b15d48ece08d63c6db21f8742c02d56a2ea0 0003-no-clean-docs.patch
+15968d95b09ed0f2315e08a5fd14e798db7fd1faebd1327ceaf7886248b61d2e61f64e726d98cd70cbc2349c66fc3a707298a2481c6abf98c699826f3f2f4ccb 0001-hardened.patch
+6530709d5cd58970b5868a6a536727df6839b3aedfe81c67d4e5b37cf840803a33027eed338b47816810b9ae1119470acd097806e90a41cd59f8d1fcb0843663 0002-verbose-build.patch
+66add07137c3baafba86aea1469ee2cf669f3fa4c01195c04c7a3f9e1b4a85dee020bef315919efa6261b675049bc251aa9fc1878ae7f7929baed5084eb697d7 0003-no-clean-docs.patch
+6c111ccdd12af5b00fdf0b7cc8fba11980fceccf7c246b40e791cd1be8e39cd75b8c290c65ebd9b4add60fc242261e17e94807736fce6a96733e9bf18182b489 0004-remove-sysctl.h.patch
9875b3cdc49bcc2812ea52b2e25836ba22058dbad94287c9aa7c4e4ee48b7819655588a08d49cb9a3c73431ff6969b3b7eb140fc96dc5b0d64777c3027e06538 0005-fix-rpath-issues.patch
a66526aee8745875b254f0d27db78b10e76cd8489f4601c77b82674a31ee7a0cf417af8b24a520e069a464303ad7f0077b75543e197eaba48a75b960c9f81a05 0008-ldconfig-compat.patch
-3f2a6cf439aaada90872b869972f17b506d2f39758f3e2407c3e5f6b28082e7797ed6f2d7e4bace56e02809fe94f879c2a34e22216aa19b08a452371b81e7462 fix-or-disable-broken-tests.patch
-be3eea9d7506796a48171d244e61e8ee3f69ee659aa65ee738a7ec08499566a014bd6ee21ba39ec97e74d734a8b45b7ec1f5a630a96a31a6d4e17b274107b640 test-disable-tests-using-fake_pty.patch
-a97a16e3b36c7c192c1133139c87b7b3a719cef645dd2435828b5b5468f4f9beb3bba0e02bb68935319dc150d0c4ccd4728c9eaedc9e2ddee2d823e881f36e2c test-libgit2-skip-SSL_CERT_FILE.patch
-fc5eef406d84b60fdf1c837aa1f5bd0e7a205c311853d0ae8b2b237e2eb750d7da2152632d866d372174918a3953746620f2bf130596ab2b027ca389a6816edd test-repl-disable-22176-20482.patch"
+1d128441bb3e15defa2b23c8d68255fe15320060ac7203ebf7d3573e9e8c0120ebf49b2256f022fdddcc816691c6271f35a27d36b03cbe203734b9f902417ca9 fix-or-disable-broken-tests.patch"
diff --git a/community/julia/fix-or-disable-broken-tests.patch b/community/julia/fix-or-disable-broken-tests.patch
index be82b33d29..fffadfb462 100644
--- a/community/julia/fix-or-disable-broken-tests.patch
+++ b/community/julia/fix-or-disable-broken-tests.patch
@@ -22,37 +22,37 @@ test/read.jl: ditto.
close(p)
--- a/test/Makefile
+++ b/test/Makefile
-@@ -6,7 +6,7 @@
+@@ -4,7 +4,7 @@
+ include $(JULIAHOME)/Make.inc
+ # TODO: this Makefile ignores BUILDDIR, except for computing JULIA_EXECUTABLE
+
+-TESTS = all linalg $(filter-out TestHelpers runtests testdefs,$(patsubst $(SRCDIR)/%.jl,%,$(wildcard $(SRCDIR)/*.jl $(SRCDIR)/linalg/*.jl)))
++TESTS = all linalg $(filter-out TestHelpers runtests testdefs libdl,$(patsubst $(SRCDIR)/%.jl,%,$(wildcard $(SRCDIR)/*.jl $(SRCDIR)/linalg/*.jl)))
+
+ default: all
- TESTGROUPS = linalg sparse unicode strings dates
- TESTS = all $(TESTGROUPS) \
-- $(filter-out TestHelpers runtests testdefs, \
-+ $(filter-out TestHelpers runtests testdefs libdl, \
- $(patsubst $(SRCDIR)/%.jl,%,$(wildcard $(SRCDIR)/*.jl))) \
- $(foreach group,$(TESTGROUPS), \
- $(patsubst $(SRCDIR)/%.jl,%,$(wildcard $(SRCDIR)/$(group)/*.jl)))
--- a/test/cmdlineargs.jl
+++ b/test/cmdlineargs.jl
-@@ -404,7 +404,7 @@
+@@ -301,7 +301,7 @@
bt = readstring(pipeline(ignorestatus(`$(Base.julia_cmd()) --startup-file=no --precompiled=$precomp
-E 'include("____nonexistent_file")'`), stderr=catcmd))
- @test contains(bt, "include_from_node1")
+ @test contains(bt, "in include_from_node1")
- if is_windows() && Sys.WORD_SIZE == 32 && precomp == "yes"
+ if ((is_windows() && Sys.WORD_SIZE == 32) || is_linux()) && precomp == "yes"
# fixme, issue #17251
- @test_broken contains(bt, "include_from_node1(::String) at $(joinpath(".","loading.jl"))")
+ @test_broken contains(bt, "in include_from_node1(::String) at $(joinpath(".","loading.jl"))")
else
--- a/test/choosetests.jl
+++ b/test/choosetests.jl
-@@ -32,7 +32,7 @@
- "replutil", "sets", "test", "goto", "llvmcall", "llvmcall2", "grisu",
+@@ -31,7 +31,7 @@
+ "replutil", "sets", "test", "goto", "llvmcall", "grisu",
"nullable", "meta", "stacktraces", "profile", "libgit2", "docs",
"markdown", "base64", "serialize", "misc", "threads",
- "enums", "cmdlineargs", "i18n", "workspace", "libdl", "int",
+ "enums", "cmdlineargs", "i18n", "workspace", "int",
- "checked", "intset", "floatfuncs", "compile", "distributed", "inline",
- "boundscheck", "error", "ambiguous", "cartesian", "asmvariant", "osutils",
- "channels", "iostream", "specificity"
+ "checked", "intset", "floatfuncs", "compile", "parallel", "inline",
+ "boundscheck", "error", "ambiguous", "cartesian"
+ ]
--- a/test/file.jl
+++ b/test/file.jl
@@ -174,8 +174,8 @@
diff --git a/community/julia/test-disable-tests-using-fake_pty.patch b/community/julia/test-disable-tests-using-fake_pty.patch
deleted file mode 100644
index a0ecd4aa35..0000000000
--- a/community/julia/test-disable-tests-using-fake_pty.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-fake_pty does not work on Alpine or just inside LXC container...?
-
-Error During Test
- Got an exception of type ErrorException outside of a @test
- Failed to open PTY master
- Stacktrace:
- [1] open_fake_pty() at test/TestHelpers.jl:31
- [2] with_fake_pty(::TestHelpers.##5#8{Int64,Cmd,Array{Any,1},TestHelpers.#format_output#7{Bool}}) at test/TestHelpers.jl:47
- [3] #challenge_prompt#4(::Int64, ::Bool, ::Function, ::Cmd, ::Array{Any,1}) at test/TestHelpers.jl:83
- [4] (::TestHelpers.#kw##challenge_prompt)(::Array{Any,1}, ::TestHelpers.#challenge_prompt, ::Cmd, ::Array{Any,1}) at ./<missing>:0
- [5] #challenge_prompt#1(::Int64, ::Bool, ::Function, ::String, ::Array{Any,1}) at test/TestHelpers.jl:68
- [6] challenge_prompt(::String, ::Array{Any,1}) at test/TestHelpers.jl:57
- [7] (::Test47Main_libgit2.##48#97)() at test/libgit2.jl:1301
-
---- a/test/repl.jl
-+++ b/test/repl.jl
-@@ -579,7 +579,7 @@
- let exename = Base.julia_cmd()
-
- # Test REPL in dumb mode
--if !is_windows()
-+if false
- TestHelpers.with_fake_pty() do slave, master
- nENV = copy(ENV)
- nENV["TERM"] = "dumb"
---- a/test/libgit2.jl
-+++ b/test/libgit2.jl
-@@ -1268,7 +1268,7 @@
- # The following tests require that we can fake a TTY so that we can provide passwords
- # which use the `getpass` function. At the moment we can only fake this on UNIX based
- # systems.
-- if is_unix()
-+ if false
- @testset "SSH credential prompt" begin
- url = "git@github.com/test/package.jl"
-
diff --git a/community/julia/test-libgit2-skip-SSL_CERT_FILE.patch b/community/julia/test-libgit2-skip-SSL_CERT_FILE.patch
deleted file mode 100644
index 51457abe9d..0000000000
--- a/community/julia/test-libgit2-skip-SSL_CERT_FILE.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-This test fails and I have no clue why. It seems that SSL_CERT_FILE is ignored.
-
-Hostname verification: Test Failed
- Expression: err.code == LibGit2.Error.ERROR
- Evaluated: ECERTIFICATE::Base.LibGit2.Error.Code = -17 == ERROR::Base.LibGit2.Error.Code = -1
-Stacktrace:
- [1] (::Test98Main_libgit2.##54#103{String,Cmd})() at test/libgit2.jl:1697
- [2] withenv(::Test98Main_libgit2.##54#103{String,Cmd}, ::Pair{String,String}, ::Vararg{Pair{String,String},N} where N) at ./env.jl:157
- [3] (::Test98Main_libgit2.##51#100)(::String) at test/libgit2.jl:1692
- [4] mktempdir(::Test98Main_libgit2.##51#100, ::String) at ./file.jl:392
- [5] macro expansion at test/libgit2.jl:1647 [inlined]
- [6] macro expansion at ./test.jl:860 [inlined]
- [7] (::Test98Main_libgit2.##7#56)(::String) at test/libgit2.jl:1606
-
---- a/test/libgit2.jl
-+++ b/test/libgit2.jl
-@@ -1694,8 +1694,8 @@
- err = open(errfile, "r") do f
- deserialize(f)
- end
-- @test err.code == LibGit2.Error.ERROR
-- @test err.msg == "Invalid Content-Type: text/plain"
-+ @test_skip err.code == LibGit2.Error.ERROR
-+ @test_skip err.msg == "Invalid Content-Type: text/plain"
- end
- finally
- kill(pobj)
diff --git a/community/julia/test-repl-disable-22176-20482.patch b/community/julia/test-repl-disable-22176-20482.patch
deleted file mode 100644
index 171a5a0476..0000000000
--- a/community/julia/test-repl-disable-22176-20482.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-There's some problem with temp file, don't know why...
-
-Error During Test
- Test threw an exception of type SystemError
- Expression: readstring(tmp) == "123\n"
- SystemError: opening file /tmp/julia_GolmjG: No such file or directory
- Stacktrace:
- [1] #systemerror#44 at ./error.jl:64 [inlined]
- [2] systemerror at ./error.jl:64
- [3] open at ./iostream.jl:104
- [4] open at ./iostream.jl:150
- [5] macro expansion at test/repl.jl:139 [inlined]
- [6] anonymous at ./<missing>:?
- [7] include_from_node1 at ./loading.jl:569
- [8] include at ./sysimg.jl:14
- [9] macro expansion at test/testdefs.jl:18 [inlined]
- [10] macro expansion at ./test.jl:860 [inlined]
- [11] macro expansion at ./util.jl:378 [inlined]
- [12] macro expansion at test/testdefs.jl:17 [inlined]
- [13] anonymous at ./<missing>:?
-
---- a/test/repl.jl
-+++ b/test/repl.jl
-@@ -126,7 +126,7 @@
-
- # issues #22176 & #20482
- # TODO: figure out how to test this on Windows
-- is_windows() || let tmp = tempname()
-+ true || let tmp = tempname()
- try
- write(stdin_write, ";")
- readuntil(stdout_read, "shell> ")