aboutsummaryrefslogtreecommitdiffstats
path: root/community/julia
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-02-11 00:40:27 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-02-11 00:40:27 +0100
commit79d4c513e4e798e7d902fee68e642940f5a76876 (patch)
tree619006e2f8ceec349edf9868752acf7eeafce535 /community/julia
parent9ec34f6e17d0830dfec0f3b0608957a87823bb35 (diff)
downloadaports-79d4c513e4e798e7d902fee68e642940f5a76876.tar.bz2
aports-79d4c513e4e798e7d902fee68e642940f5a76876.tar.xz
community/julia: temporarily remove noarch mark from -tests
>>> julia-tests*: Running split function tests... >>> julia-tests*: Preparing subpackage julia-tests... >>> ERROR: julia-tests*: Arch specific binaries found so arch must not be set to "noarch" >>> ERROR: julia-tests*: prepare_package failed >>> ERROR: julia*: prepare_subpackages failed >>> ERROR: julia: all failed This is non-sense, -tests does not contain any binaries, I can't reproduce this error locally.
Diffstat (limited to 'community/julia')
-rw-r--r--community/julia/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/community/julia/APKBUILD b/community/julia/APKBUILD
index 8e007e79ad..c3d86cea82 100644
--- a/community/julia/APKBUILD
+++ b/community/julia/APKBUILD
@@ -51,7 +51,9 @@ makedepends="$depends_dev
paxmark
perl
"
-subpackages="$pkgname-tests::noarch $pkgname-doc $pkgname-dev $pkgname-dbg"
+# FIXME: -tests should be noarch, but for unknown reason it fails on builder
+# (arch-specific binaries are found)...
+subpackages="$pkgname-tests $pkgname-doc $pkgname-dev $pkgname-dbg"
source="https://github.com/JuliaLang/julia/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
libuv-$_libuv_ver.tar.gz::https://api.github.com/repos/JuliaLang/libuv/tarball/$_libuv_ver
UnicodeData.txt-9.0.0::http://www.unicode.org/Public/9.0.0/ucd/UnicodeData.txt