aboutsummaryrefslogtreecommitdiffstats
path: root/community/julia
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-02-10 00:59:59 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-02-10 14:22:11 +0100
commitccc266c812b8ae5f3f909bb402fe8c43a78355d1 (patch)
treed52b931878c8105ca1d6c710b5f81d69866959c8 /community/julia
parent136745b4639d08fb13c3823db7d2a7d6f36a5fd6 (diff)
downloadaports-ccc266c812b8ae5f3f909bb402fe8c43a78355d1.tar.bz2
aports-ccc266c812b8ae5f3f909bb402fe8c43a78355d1.tar.xz
community/julia: fix build, fix -dbg subpkg and include HTML docs
Diffstat (limited to 'community/julia')
-rw-r--r--community/julia/APKBUILD22
-rw-r--r--community/julia/makefile-dont-rebuild-docs.patch12
2 files changed, 26 insertions, 8 deletions
diff --git a/community/julia/APKBUILD b/community/julia/APKBUILD
index c991acc97d..6f7ca874ad 100644
--- a/community/julia/APKBUILD
+++ b/community/julia/APKBUILD
@@ -51,7 +51,7 @@ makedepends="$depends_dev
paxmark
perl
"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg"
+subpackages="$pkgname-doc $pkgname-dev $pkgname-dbg"
source="https://github.com/JuliaLang/julia/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
libuv-$_libuv_ver.tar.gz::https://api.github.com/repos/JuliaLang/libuv/tarball/$_libuv_ver
UnicodeData.txt-9.0.0::http://www.unicode.org/Public/9.0.0/ucd/UnicodeData.txt
@@ -65,6 +65,7 @@ source="https://github.com/JuliaLang/julia/releases/download/v$pkgver/$pkgname-$
test-disable-tests-using-fake_pty.patch
test-libgit2-skip-SSL_CERT_FILE.patch
test-repl-disable-22176-20482.patch
+ makefile-dont-rebuild-docs.patch
"
builddir="$srcdir/$pkgname-$pkgver"
ldpath="/usr/lib/julia"
@@ -99,6 +100,7 @@ prepare() {
LIBLAPACKNAME=libopenblas
LLVM_CONFIG=/usr/lib/llvm$_llvm_ver/bin/llvm-config
LLVM_VER=$_llvm_ver
+ NO_GIT=1
USE_SYSTEM_LLVM=1
USE_SYSTEM_LIBUNWIND=1
USE_SYSTEM_PCRE=1
@@ -139,9 +141,8 @@ prepare() {
build() {
cd "$builddir"
- # If we don't clean here, then make install will recompile everything,
- # don't know why...
- make clean && make release
+ # If debug is not built here, it is built during make install.
+ make release debug
}
check() {
@@ -160,19 +161,23 @@ package() {
install -D "$srcdir"/find-syslibs "$pkgdir"/usr/share/julia/find-syslibs
# re-apply lost PaX markings
paxmark m "$pkgdir"/usr/bin/julia "$pkgdir"/usr/bin/julia-debug
+
+ rm -Rf "$pkgdir"/usr/share/julia/site
}
+# Note: Julia builds somehow special debug binaries, so we need to bypass
+# default_dbg and just copy them as-is.
dbg() {
pkgdesc="$pkgdesc (debug build)"
+ depends="$pkgname=$pkgver-r$pkgrel"
replaces="$pkgname-debug"
- default_dbg
install -d "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/*-debug "$subpkgdir"/usr/bin/
install -d "$subpkgdir"/usr/lib/julia
- mv "$pkgdir"/usr/lib/*-debug.* "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/julia/*-debug.* "$subpkgdir"/usr/lib/julia/
+ mv "$pkgdir"/usr/lib/*[.-]debug* "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/julia/*[.-]debug* "$subpkgdir"/usr/lib/julia/
}
sha512sums="679050463ed5825d34c477bd44cd91cfecc7d1735a2f52cc70b509afd9883cb60902861643266ecac5ba6cbb03f8fcdd12fc2e87dc41b9ed0eef813fa40610f1 julia-0.6.2.tar.gz
@@ -187,4 +192,5 @@ e1257c42b819bbdcdca74c7b912c1e0e43d6ba70c5e8625d6141bb2dcc49abbab5a8690046bf6cc1
e989a1f39a68de3378cedd6d009ae07af1888eb7a39b2f18c2441c06b75305f0cff90d8bef28bb2d0d84422435713060ffe07f244994a2941d591c66ac1cb131 fix-or-disable-broken-tests.patch
8d4608dd90735ffdbdb04e1dc27fc9702624e45969ab379401d5b605cccf78dea9a79d713995358b552532ae938212ee0f032e5ce7e6c28edb30c49c02b58e7b test-disable-tests-using-fake_pty.patch
87267dd0402d8e70dd511bd79c7edfc3d1b5db7dbbdc9618832adb73ab7d34c6eed2c347fe74bf93757cc6b4f573ed7918d733b3bbf3653eab06f65a74428ff4 test-libgit2-skip-SSL_CERT_FILE.patch
-fc5eef406d84b60fdf1c837aa1f5bd0e7a205c311853d0ae8b2b237e2eb750d7da2152632d866d372174918a3953746620f2bf130596ab2b027ca389a6816edd test-repl-disable-22176-20482.patch"
+fc5eef406d84b60fdf1c837aa1f5bd0e7a205c311853d0ae8b2b237e2eb750d7da2152632d866d372174918a3953746620f2bf130596ab2b027ca389a6816edd test-repl-disable-22176-20482.patch
+98a25c49465771e72c1c0d114602c6937dbddac3e81255b310a0309083b4b365c35eb37f7a7c6128b3369dd1a071cc5c16c18aa9628dd355defd0fcb0f289706 makefile-dont-rebuild-docs.patch"
diff --git a/community/julia/makefile-dont-rebuild-docs.patch b/community/julia/makefile-dont-rebuild-docs.patch
new file mode 100644
index 0000000000..8e067a09ca
--- /dev/null
+++ b/community/julia/makefile-dont-rebuild-docs.patch
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -338,8 +338,7 @@
+ $(build_depsbindir)/stringreplace $$(strings -t x - $1 | grep '$2' | awk '{print $$1;}') '$3' 255 "$(call cygpath_w,$1)"
+ endef
+
+-install: $(build_depsbindir)/stringreplace $(BUILDROOT)/doc/_build/html/en/index.html
+- @$(MAKE) $(QUIET_MAKE) all
++install: $(build_depsbindir)/stringreplace
+ @for subdir in $(bindir) $(datarootdir)/julia/site/$(VERSDIR) $(docdir) $(man1dir) $(includedir)/julia $(libdir) $(private_libdir) $(sysconfdir); do \
+ mkdir -p $(DESTDIR)$$subdir; \
+ done