aboutsummaryrefslogtreecommitdiffstats
path: root/community/kaccounts-providers
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-01-13 15:38:24 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-13 17:23:49 +0100
commit69b722d115429704d3989595ce5567e1c74b6d25 (patch)
tree7582bb20af2b9423cbca3b7ae00a15caedfa50c3 /community/kaccounts-providers
parent5f3bd5f35c2a6dde5ff4b4d82bee5650f378a3b9 (diff)
downloadaports-69b722d115429704d3989595ce5567e1c74b6d25.tar.bz2
aports-69b722d115429704d3989595ce5567e1c74b6d25.tar.xz
community/kaccounts-providers: fix Google provider
As suggested by upstream. Will be part of KDE Applications 19.12.2 in February
Diffstat (limited to 'community/kaccounts-providers')
-rw-r--r--community/kaccounts-providers/APKBUILD8
-rw-r--r--community/kaccounts-providers/fix-online-accounts-google.patch55
2 files changed, 60 insertions, 3 deletions
diff --git a/community/kaccounts-providers/APKBUILD b/community/kaccounts-providers/APKBUILD
index 76cf38708a..79e0da7ce3 100644
--- a/community/kaccounts-providers/APKBUILD
+++ b/community/kaccounts-providers/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kaccounts-providers
pkgver=19.12.0
-pkgrel=0
+pkgrel=1
arch="all"
url="https://kde.org/applications/internet/"
pkgdesc="Small system to administer web accounts for the sites and services across the KDE desktop"
license="GPL-2.0-or-later"
depends="kaccounts-integration"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev kio-dev ki18n-dev kdeclarative-dev kpackage-dev kaccounts-integration-dev intltool"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kaccounts-providers-$pkgver.tar.xz"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kaccounts-providers-$pkgver.tar.xz
+ fix-online-accounts-google.patch"
subpackages="$pkgname-lang"
prepare() {
@@ -32,4 +33,5 @@ package() {
DESTDIR="$pkgdir" make install
}
-sha512sums="0bc9be70592f7e9a4e8eecf771f86bc89201a97627e177afe071e8581b1ce5c04a304dd3a0f0667e120b7a32b8d6f34558fa42d03460080c71ebfb84800a4278 kaccounts-providers-19.12.0.tar.xz"
+sha512sums="0bc9be70592f7e9a4e8eecf771f86bc89201a97627e177afe071e8581b1ce5c04a304dd3a0f0667e120b7a32b8d6f34558fa42d03460080c71ebfb84800a4278 kaccounts-providers-19.12.0.tar.xz
+736b84854dad5da887c9d270b8bfe5782ded908c4fa463d7ecfa8218dfdc12956123515e86eb41f75d5427d5ae9c20c194ff5cead62e81afb3bcb59d77235d9c fix-online-accounts-google.patch"
diff --git a/community/kaccounts-providers/fix-online-accounts-google.patch b/community/kaccounts-providers/fix-online-accounts-google.patch
new file mode 100644
index 0000000000..e303e5ce24
--- /dev/null
+++ b/community/kaccounts-providers/fix-online-accounts-google.patch
@@ -0,0 +1,55 @@
+From 0a71da4e3caae0defe200a85954fc7e2012010c1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Daniel=20Vr=C3=A1til?= <dvratil@kde.org>
+Date: Mon, 13 Jan 2020 13:48:37 +0100
+Subject: Google provider: limit requested OAuth scopes
+
+Summary:
+Limit the scopes to what is actually permitted in the Google App settings:
+contacts and calendars for future PIM integration, GDrive for KIO-GDrive,
+and Youtube (upload-only) for the Purpose sharing plugin. We can extend
+this in the future if needed easilly, it's easier for us to get the
+Google App verified if we can proof and show how the individual scopes
+are used by KDE.
+
+Reviewers: elvisangelaccio, bshah
+
+Reviewed By: elvisangelaccio, bshah
+
+Differential Revision: https://phabricator.kde.org/D26454
+---
+ providers/google.provider.in | 13 +++----------
+ 1 file changed, 3 insertions(+), 10 deletions(-)
+
+diff --git a/providers/google.provider.in b/providers/google.provider.in
+index 638c1a9..97307af 100644
+--- a/providers/google.provider.in
++++ b/providers/google.provider.in
+@@ -21,22 +21,15 @@
+ order to return a refresh token -->
+ <setting name="ResponseType">code</setting>
+ <setting name="Scope" type="as">[
+- 'https://docs.google.com/feeds/',
+- 'https://www.googleapis.com/auth/googletalk',
+- 'https://www.googleapis.com/auth/youtube.upload',
+- 'https://www.googleapis.com/auth/youtube',
+ 'https://www.googleapis.com/auth/userinfo.email',
+ 'https://www.googleapis.com/auth/userinfo.profile',
+- 'https://picasaweb.google.com/data/',
+ 'https://www.googleapis.com/auth/calendar',
+- 'https://www.google.com/m8/feeds/',
+ 'https://www.googleapis.com/auth/tasks',
++ 'https://www.google.com/m8/feeds/',
+ 'https://www.googleapis.com/auth/drive',
+- 'https://www.googleapis.com/auth/drive.file',
+- 'https://www.googleapis.com/auth/drive.metadata.readonly',
+- 'https://www.googleapis.com/auth/drive.readonly'
++ 'https://www.googleapis.com/auth/youtube.upload',
+ ]</setting>
+- <setting name="AllowedSchemes" type="as">['https','http']</setting>
++ <setting name="AllowedSchemes" type="as">['https']</setting>
+ <setting name="ClientId">317066460457-pkpkedrvt2ldq6g2hj1egfka2n7vpuoo.apps.googleusercontent.com</setting>
+ <setting name="ClientSecret">Y8eFAaWfcanV3amZdDvtbYUq</setting>
+ <setting name="ForceClientAuthViaRequestBody" type="b">true</setting>
+--
+cgit v1.1
+