aboutsummaryrefslogtreecommitdiffstats
path: root/community/kaidan
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-12-06 21:50:44 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-06 22:41:02 +0100
commit3a6c111c786c9574aadbec4c8cda524a8a32c1b0 (patch)
tree60972fc1b4d53d9abab355b78dbbb65be0670b23 /community/kaidan
parent78491bc8fc40984f1ee03f0bceff0a1b740ed5fc (diff)
downloadaports-3a6c111c786c9574aadbec4c8cda524a8a32c1b0.tar.bz2
aports-3a6c111c786c9574aadbec4c8cda524a8a32c1b0.tar.xz
community/kaidan: move from testing
Diffstat (limited to 'community/kaidan')
-rw-r--r--community/kaidan/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/kaidan/APKBUILD b/community/kaidan/APKBUILD
new file mode 100644
index 0000000000..9633b51cff
--- /dev/null
+++ b/community/kaidan/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kaidan
+pkgver=0.4.1
+pkgrel=0
+pkgdesc="Kaidan, a simple and user-friendly Jabber/XMPP client for every device and platform"
+arch="all"
+url="https://invent.kde.org/kde/kaidan"
+license="GPL-3.0-or-later with OpenSSL exception, GPL-3.0-or-later, MIT, CC-BY-SA-4.0"
+depends="kirigami2"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtsvg-dev qt5-qtquickcontrols2-dev qt5-qttools-dev kirigami2-dev knotifications-dev qxmpp-dev"
+source="https://download.kde.org/stable/kaidan/$pkgver/kaidan-$pkgver.tar.xz"
+options="!check" # No tests
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DQUICK_COMPILER=TRUE \
+ -DI18N=TRUE
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="907ef5824a781f5cc55af1dfe4a52fe058057585826fecfd2d4d039bdfb3241ec1189fbd34f89fe0aa381b9c86ba418bc1d020324a32466a3b8304783542363e kaidan-0.4.1.tar.xz"