aboutsummaryrefslogtreecommitdiffstats
path: root/community/kaidan
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-03-27 15:08:42 +0100
committerTBK <tbk@jjtc.eu>2020-03-27 14:27:46 +0000
commitf6cd038baecd72f5c2a588a21d24068d13273b2a (patch)
tree8ae3e58aa513f5cd36f4c3f1b66410f98189dfcb /community/kaidan
parent699789b9dade7099f3ffdbf904230897a8cd4daf (diff)
downloadaports-f6cd038baecd72f5c2a588a21d24068d13273b2a.tar.bz2
aports-f6cd038baecd72f5c2a588a21d24068d13273b2a.tar.xz
community/kaidan: rebuild against qt5-qtdeclarative 5.14.1
Diffstat (limited to 'community/kaidan')
-rw-r--r--community/kaidan/APKBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/community/kaidan/APKBUILD b/community/kaidan/APKBUILD
index 34eb68f098..69439c6bba 100644
--- a/community/kaidan/APKBUILD
+++ b/community/kaidan/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kaidan
pkgver=0.4.1
-pkgrel=3
+pkgrel=4
pkgdesc="Kaidan, a simple and user-friendly Jabber/XMPP client for every device and platform"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
url="https://invent.kde.org/kde/kaidan"
@@ -12,31 +12,23 @@ makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtsvg-
source="https://download.kde.org/stable/kaidan/$pkgver/kaidan-$pkgver.tar.xz"
options="!check" # No tests
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build
-}
-
build() {
- cd "$builddir"/build
- cmake "$builddir" \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DQUICK_COMPILER=TRUE \
-DI18N=TRUE
- make
+ make -C build
}
check() {
- cd "$builddir"/build
+ cd build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" make -C build install
}
sha512sums="907ef5824a781f5cc55af1dfe4a52fe058057585826fecfd2d4d039bdfb3241ec1189fbd34f89fe0aa381b9c86ba418bc1d020324a32466a3b8304783542363e kaidan-0.4.1.tar.xz"