aboutsummaryrefslogtreecommitdiffstats
path: root/community/kapidox
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-14 19:46:37 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-17 12:13:50 -0300
commit49afd00440e7a1725cb4701a2ff879e994a55389 (patch)
tree915f5c810b7027a5a99e9ed935ab50f9d8dde87e /community/kapidox
parente58bd7992d0d7b657f02561eb4c255bdfe6751d6 (diff)
downloadaports-49afd00440e7a1725cb4701a2ff879e994a55389.tar.bz2
aports-49afd00440e7a1725cb4701a2ff879e994a55389.tar.xz
community/kde-frameworks: upgrade to 5.63.0
Diffstat (limited to 'community/kapidox')
-rw-r--r--community/kapidox/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/kapidox/APKBUILD b/community/kapidox/APKBUILD
index 30697418c9..f6e7110a09 100644
--- a/community/kapidox/APKBUILD
+++ b/community/kapidox/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kapidox
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
arch="noarch"
pkgdesc="Scripts and data for building API documentation (dox) in a standard format and style"
@@ -12,8 +12,15 @@ makedepends="extra-cmake-modules python3-dev"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kapidox-$pkgver.tar.xz"
subpackages="$pkgname-doc"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -22,10 +29,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="d962d374530fcb264d83fc223b055a86a7bec6cc11c192cc8972e703a4a505520547c9eac2be758847cbfcf73ab63d6ba09dd70c7f1fa3ec5437d7ca844ec6da kapidox-5.62.0.tar.xz"
+sha512sums="408d03720b5511587c5246a263be276b8acda9fa892fac6b1956b7a9259aca695c145e7678fe5852e31fd162547051131c649bda884bd008d737136b7eba74fd kapidox-5.63.0.tar.xz"