aboutsummaryrefslogtreecommitdiffstats
path: root/community/kapidox
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-14 00:55:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 22:20:39 -0300
commitc702f2a812cfbc5c0c1a68b6f120cf332f788f1f (patch)
tree800e1687809b5e688995a9948d19af9e577a167d /community/kapidox
parent8d48f29796e55f6906ecb8cb8ef27e1b4dc3b820 (diff)
downloadaports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.bz2
aports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.xz
community/kde-frameworks: move from testing
Diffstat (limited to 'community/kapidox')
-rw-r--r--community/kapidox/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/kapidox/APKBUILD b/community/kapidox/APKBUILD
new file mode 100644
index 0000000000..aa2c2d66bd
--- /dev/null
+++ b/community/kapidox/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kapidox
+pkgver=5.60.0
+pkgrel=0
+arch="noarch"
+pkgdesc="Scripts and data for building API documentation (dox) in a standard format and style"
+url="https://community.kde.org/Frameworks"
+license="BSD-3-Clause"
+depends="python3 py3-yaml py3-jinja2 doxygen"
+makedepends="extra-cmake-modules python3-dev"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="f2ee7a486a3740ad2124f95264f83242b07454f189defc8eefac1cb20e7b6b1c37c579fd8b620148ee2197b8473d3a5a80e773fb0f0abd2f6cdfca7a4a1bcea6 kapidox-5.60.0.tar.xz"