aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcalc/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-10 13:30:30 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-10 12:41:47 -0300
commit7a53b050efaef2d3e2a3cced51a5b4a5b947a789 (patch)
treec9ea3b9a35928e11f959e5f9396f8e648571faa4 /community/kcalc/APKBUILD
parent4106e0454902f36bfc5c1e52f0290001041ae40e (diff)
downloadaports-7a53b050efaef2d3e2a3cced51a5b4a5b947a789.tar.bz2
aports-7a53b050efaef2d3e2a3cced51a5b4a5b947a789.tar.xz
community/kcalc: move from testing
Diffstat (limited to 'community/kcalc/APKBUILD')
-rw-r--r--community/kcalc/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/kcalc/APKBUILD b/community/kcalc/APKBUILD
new file mode 100644
index 0000000000..8ec98f2458
--- /dev/null
+++ b/community/kcalc/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kcalc
+pkgver=19.08.1
+pkgrel=1
+arch="all"
+url="https://kde.org/applications/utilities/org.kde.kcalc"
+pkgdesc="Scientific Calculator"
+license="GPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev kcrash-dev kconfig-dev kconfigwidgets-dev kdoctools-dev kguiaddons-dev ki18n-dev kinit-dev knotifications-dev kxmlgui-dev gmp-dev mpfr-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="6a4aae7569165d291518613005c71f54b74b17f747b003bfd1fc71f938c7676903d2a83adb742b938aff3e1ba8e71dcaa56d6a8c76a37398d2a7a602e3b90a5e kcalc-19.08.1.tar.xz"