aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdbusaddons
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-14 19:46:37 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-17 12:13:50 -0300
commit49afd00440e7a1725cb4701a2ff879e994a55389 (patch)
tree915f5c810b7027a5a99e9ed935ab50f9d8dde87e /community/kdbusaddons
parente58bd7992d0d7b657f02561eb4c255bdfe6751d6 (diff)
downloadaports-49afd00440e7a1725cb4701a2ff879e994a55389.tar.bz2
aports-49afd00440e7a1725cb4701a2ff879e994a55389.tar.xz
community/kde-frameworks: upgrade to 5.63.0
Diffstat (limited to 'community/kdbusaddons')
-rw-r--r--community/kdbusaddons/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/kdbusaddons/APKBUILD b/community/kdbusaddons/APKBUILD
index 411ad98047..d457f27325 100644
--- a/community/kdbusaddons/APKBUILD
+++ b/community/kdbusaddons/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdbusaddons
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
pkgdesc="Addons to QtDBus"
arch="all"
@@ -12,8 +12,15 @@ source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kdbusaddons-$pkg
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
options="!check" # Requires running dbus-daemon
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -22,10 +29,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="8a9fe79778c8baf7ebec2daeb594a06c27ab2af41bc0c8bcd36064a6a0721eedb0cdfbf3416f13942652e6b3181688dfb392a3d245788e75206a76fb19f73f6b kdbusaddons-5.62.0.tar.xz"
+sha512sums="48341a4f887df1e139eed4504ba6f2104084c451a6a3e825fd53ebefeb33b7310eff56fcdb368aed905c41a97f27ee0c51bffe7b3dd15b1d5b05009aab874452 kdbusaddons-5.63.0.tar.xz"