aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdbusaddons
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-14 00:55:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 22:20:39 -0300
commitc702f2a812cfbc5c0c1a68b6f120cf332f788f1f (patch)
tree800e1687809b5e688995a9948d19af9e577a167d /community/kdbusaddons
parent8d48f29796e55f6906ecb8cb8ef27e1b4dc3b820 (diff)
downloadaports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.bz2
aports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.xz
community/kde-frameworks: move from testing
Diffstat (limited to 'community/kdbusaddons')
-rw-r--r--community/kdbusaddons/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/kdbusaddons/APKBUILD b/community/kdbusaddons/APKBUILD
new file mode 100644
index 0000000000..139a1f85b8
--- /dev/null
+++ b/community/kdbusaddons/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kdbusaddons
+pkgver=5.60.0
+pkgrel=0
+pkgdesc="Addons to QtDBus"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-only OR LGPL-3.0-only"
+makedepends="extra-cmake-modules qt5-qttools-dev doxygen shared-mime-info"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+options="!check" # Requires running dbus-daemon
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="d589abeec760fd2937fa3f7d7c63407429f2afbca68156c8014208df87929f16544ea738936c08f3112b761e42204eca9a6b8fa2e4611c88e46cbc2acc6e50c2 kdbusaddons-5.60.0.tar.xz"