aboutsummaryrefslogtreecommitdiffstats
path: root/community/keepalived/fix-configure.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-19 02:33:33 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-19 02:34:01 +0100
commit813ce7dc6afa78c1ef3e67ada1d8005557efc540 (patch)
treea06f35c0ed370816814b149286caa4be34ac21f1 /community/keepalived/fix-configure.patch
parent430f0751b62c42901c4cbedea3e6baeceb7314e6 (diff)
downloadaports-813ce7dc6afa78c1ef3e67ada1d8005557efc540.tar.bz2
aports-813ce7dc6afa78c1ef3e67ada1d8005557efc540.tar.xz
community/keepalived: move from testing
Diffstat (limited to 'community/keepalived/fix-configure.patch')
-rw-r--r--community/keepalived/fix-configure.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/community/keepalived/fix-configure.patch b/community/keepalived/fix-configure.patch
new file mode 100644
index 0000000000..14c43d8048
--- /dev/null
+++ b/community/keepalived/fix-configure.patch
@@ -0,0 +1,46 @@
+From 4b6ceb48080044d675bc67ac93a86513b61eea63 Mon Sep 17 00:00:00 2001
+From: Jakub Jirutka <jakub@jirutka.cz>
+Date: Sat, 19 Nov 2016 01:43:24 +0100
+Subject: [PATCH] Fix illegal syntax in configure script
+
+Indirect expansion (`${!foo}`) is a bashism, it's not POSIX-sh
+compatible and is not supported by common shells except Bash and ZSH!
+Configure script should be portable, hence strictly POSIX compliant.
+Moreover it has shebang /bin/sh.
+
+Sent to upstream: https://github.com/acassen/keepalived/pull/456
+---
+ configure | 4 ++--
+ configure.ac | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/configure b/configure
+index bfd0acb..c6085e2 100755
+--- a/configure
++++ b/configure
+@@ -7087,8 +7087,8 @@ cat >>confdefs.h <<_ACEOF
+ _ACEOF
+
+ for flag in RTA_ENCAP RTA_EXPIRES RTA_NEWDST RTA_PREF RTA_VIA FRA_OIFNAME FRA_SUPPRESS_PREFIXLEN FRA_SUPPRESS_IFGROUP FRA_TUN_ID RTAX_CC_ALGO RTAX_QUICKACK; do
+- decl_var=ac_cv_have_decl_$flag
+- if test ${!decl_var} = yes; then
++ eval decl_var=\$ac_cv_have_decl_$flag
++ if test ${decl_var} = yes; then
+ BUILD_OPTIONS="$BUILD_OPTIONS "${flag}
+ fi
+ done
+diff --git a/configure.ac b/configure.ac
+index 2496be1..15ffc40 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -422,8 +422,8 @@ AC_CHECK_DECLS([RTA_VIA, FRA_OIFNAME], [], [],
+ #include <sys/socket.h>
+ #include <linux/fib_rules.h>]])
+ for flag in RTA_ENCAP RTA_EXPIRES RTA_NEWDST RTA_PREF RTA_VIA FRA_OIFNAME FRA_SUPPRESS_PREFIXLEN FRA_SUPPRESS_IFGROUP FRA_TUN_ID RTAX_CC_ALGO RTAX_QUICKACK; do
+- decl_var=ac_cv_have_decl_$flag
+- if test ${!decl_var} = yes; then
++ AS_VAR_COPY([decl_var], [ac_cv_have_decl_$flag])
++ if test ${decl_var} = yes; then
+ add_build_opt[${flag}]
+ fi
+ done