aboutsummaryrefslogtreecommitdiffstats
path: root/community/keepassxc/APKBUILD
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-06-12 19:05:29 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-12 19:12:19 +0000
commitd3a2d7ece7e2e1b6cac58a84f019fb5f1ab39737 (patch)
treeac43d472241992ba5b1b01998b6c1f0256de1fa1 /community/keepassxc/APKBUILD
parent75e2806450d31a5355bece9c87429a5b16f8a49b (diff)
downloadaports-d3a2d7ece7e2e1b6cac58a84f019fb5f1ab39737.tar.bz2
aports-d3a2d7ece7e2e1b6cac58a84f019fb5f1ab39737.tar.xz
community/keepassxc: move from testing
Diffstat (limited to 'community/keepassxc/APKBUILD')
-rw-r--r--community/keepassxc/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/keepassxc/APKBUILD b/community/keepassxc/APKBUILD
new file mode 100644
index 0000000000..ce85391c4c
--- /dev/null
+++ b/community/keepassxc/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Contributor: August Klein <amatcoder@gmail.com>
+# Contributor: Orson Teodoro <orsonteodoro@hotmail.com>
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Orson Teodoro <orsonteodoro@hotmail.com>
+
+pkgname=keepassxc
+pkgver=2.4.3
+pkgrel=0
+pkgdesc="Community-driven port of the Windows application Keepass Password Safe"
+url="https://keepassxc.org/"
+arch="all"
+license="GPL-3.0 BSD-3-Clause CC0-1.0 LGPL-2.0-only LGPL-2.1-only \
+ LGPL-3.0-or-later Nokia-Qt-exception-1.1 MIT BSL-1.0"
+depends="icu-libs"
+makedepends="cmake qt5-qtbase-dev qt5-qttools-dev libxtst-dev qt5-qtsvg-dev libqrencode-dev \
+ qt5-qtx11extras-dev libgcrypt-dev libgpg-error-dev argon2-dev zlib-dev \
+ libsodium-dev"
+source="https://github.com/keepassxreboot/$pkgname/releases/download/$pkgver/$pkgname-$pkgver-src.tar.xz"
+builddir="$srcdir"/$pkgname-$pkgver
+subpackages="$pkgname-doc"
+
+build() {
+ cd "$builddir"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DWITH_XC_KEESHARE=ON \
+ -DKEEPASSXC_BUILD_TYPE=Release .
+ make
+}
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -d "$pkgdir"/usr/share/doc/$pkgname/ \
+ "$pkgdir"/usr/share/licenses/$pkgname/
+ install -t "$pkgdir"/usr/share/doc/$pkgname/ \
+ "$builddir"/CHANGELOG "$builddir"/README.md
+ install -t "$pkgdir"/usr/share/licenses/$pkgname/ \
+ "$builddir"/LICENSE.NOKIA-LGPL-EXCEPTION \
+ "$builddir"/LICENSE.CC0 "$builddir"/COPYING
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+sha512sums="893f1d18ab8051143d29c568ba87adcc42a13d28d0c3a7af04396cd91d6724f8a98d76d2e20ca15138c4642ec060d48b9e957857251f3a0df6066af08cd0765d keepassxc-2.4.3-src.tar.xz"