aboutsummaryrefslogtreecommitdiffstats
path: root/community/khotkeys/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-18 16:13:36 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-20 12:24:41 -0300
commitb3553abc60cd45495f8a252a5a06ca25c6749952 (patch)
tree89dc4e90e78d313a485ccb0fd7264c132d9d4381 /community/khotkeys/APKBUILD
parent9a177212eb91a159b575312d0824a790ad551adf (diff)
downloadaports-b3553abc60cd45495f8a252a5a06ca25c6749952.tar.bz2
aports-b3553abc60cd45495f8a252a5a06ca25c6749952.tar.xz
community/plasma: upgrade to 5.17.0
Diffstat (limited to 'community/khotkeys/APKBUILD')
-rw-r--r--community/khotkeys/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/khotkeys/APKBUILD b/community/khotkeys/APKBUILD
index 22f20aee28..fa32aafd95 100644
--- a/community/khotkeys/APKBUILD
+++ b/community/khotkeys/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=khotkeys
-pkgver=5.16.5
+pkgver=5.17.0
pkgrel=0
arch="all !ppc64le !s390x" # Limited by plasma-workspace-dev
url="https://www.kde.org/workspaces/plasmadesktop/"
@@ -12,8 +12,15 @@ source="https://download.kde.org/stable/plasma/$pkgver/khotkeys-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang $pkgname-dev"
options="!check" # No tests
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -21,11 +28,13 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="f389396c058dc261a16f6a73f88babc24dc1d7226e35d798c77629bd3e15f1dc9bc2923f2eedb601df6517b168c251c8c6341f364ee14facf4d267e9e5358f34 khotkeys-5.16.5.tar.xz"
+sha512sums="bce865fc23d0662b588280629d837ac682ece2b6a56ab58fcfffb8a9e99dbf9af0904362b3571cc2e3d3d94d5a1bd8877cf4b7b9426ce58b4c6fb0d00b716d17 khotkeys-5.17.0.tar.xz"