aboutsummaryrefslogtreecommitdiffstats
path: root/community/kinit
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-14 00:55:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 22:20:39 -0300
commitc702f2a812cfbc5c0c1a68b6f120cf332f788f1f (patch)
tree800e1687809b5e688995a9948d19af9e577a167d /community/kinit
parent8d48f29796e55f6906ecb8cb8ef27e1b4dc3b820 (diff)
downloadaports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.bz2
aports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.xz
community/kde-frameworks: move from testing
Diffstat (limited to 'community/kinit')
-rw-r--r--community/kinit/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/kinit/APKBUILD b/community/kinit/APKBUILD
new file mode 100644
index 0000000000..20c4d575d7
--- /dev/null
+++ b/community/kinit/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kinit
+pkgver=5.60.0
+pkgrel=0
+pkgdesc="Process launcher to speed up launching KDE applications"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-only OR LGPL-3.0-only"
+depends_dev="qt5-qtbase-dev libcap-dev kservice-dev kio-dev ki18n-dev kwindowsystem-dev kcrash-dev kconfig-dev"
+makedepends="$depends_dev extra-cmake-modules kdoctools-dev"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="68a6511a5e952b362d63f59e4034892b45aea17067401491072a638046b5d464573de19ecccf0a0d700b95d36ff8d507f1c0f0e936ef54e62640267b76c5340c kinit-5.60.0.tar.xz"