aboutsummaryrefslogtreecommitdiffstats
path: root/community/konsole
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-04-24 13:45:31 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2020-04-29 12:14:48 +0000
commit864c859e9deeda2c68e8310550ca3c6d70a28dd7 (patch)
tree563a4f34e066ef22550ad61b1a57ef73b73a01e7 /community/konsole
parent8299de333bd41be1fe498d779f960ae216b9b5d7 (diff)
downloadaports-864c859e9deeda2c68e8310550ca3c6d70a28dd7.tar.bz2
aports-864c859e9deeda2c68e8310550ca3c6d70a28dd7.tar.xz
community/kde-applications: upgrade to 20.04.0
Diffstat (limited to 'community/konsole')
-rw-r--r--community/konsole/APKBUILD10
-rw-r--r--community/konsole/fix-kshortcuts-5.69.patch115
2 files changed, 4 insertions, 121 deletions
diff --git a/community/konsole/APKBUILD b/community/konsole/APKBUILD
index bdbd7d87c4..dc72807045 100644
--- a/community/konsole/APKBUILD
+++ b/community/konsole/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=konsole
-pkgver=19.12.3
-pkgrel=1
+pkgver=20.04.0
+pkgrel=0
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
url="https://kde.org/applications/system/konsole"
pkgdesc="KDE's terminal emulator"
@@ -15,8 +15,7 @@ makedepends="extra-cmake-modules qt5-qtbase-dev kbookmarks-dev kcompletion-dev
ktextwidgets-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev
kglobalaccel-dev kdoctools-dev"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/konsole-$pkgver.tar.xz
- fix-kshortcuts-5.69.patch"
+source="https://download.kde.org/stable/release-service/$pkgver/src/konsole-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
build() {
@@ -37,5 +36,4 @@ package() {
DESTDIR="$pkgdir" make -C build install
}
-sha512sums="980a7eab4efb219acdda8873318980ba14cf7d3fc4f78ac171f8ed1e11400b3028150140aac192820771a0ac8e596fc0f6497c4a44d74bbd1c421f72a39da289 konsole-19.12.3.tar.xz
-0bebb29a00987d9b5c058bb34af27514f24be0a331f5daf15e3ef6960f3b446beb4a05955e8a56da3236d1f32a96e399dcba3470fbe10374bfcbe5784c5e1af3 fix-kshortcuts-5.69.patch"
+sha512sums="eb260752cf62c418349a8a2ee91e5a9a8f0450190f6d8ffe3c6ac4d7131e858e84f0f520c447588f60143564eaac9b5f340d90562fe507ec27846a82d0bc73f4 konsole-20.04.0.tar.xz"
diff --git a/community/konsole/fix-kshortcuts-5.69.patch b/community/konsole/fix-kshortcuts-5.69.patch
deleted file mode 100644
index 0d596f591d..0000000000
--- a/community/konsole/fix-kshortcuts-5.69.patch
+++ /dev/null
@@ -1,115 +0,0 @@
-From 6db7f8d2593ccb0238b2b547ed6eaf7da6a26c4c Mon Sep 17 00:00:00 2001
-From: Ahmad Samir <a.samirh78@gmail.com>
-Date: Mon, 13 Apr 2020 11:30:47 +0200
-Subject: [BookmarkMenu] Adapt the code to KBookmarks 5.69 changes
-
-Starting from KBookmarks 5.69 the ctor that took a KActionCollection
-parameter has been deprecated, and we need to manually add the various
-bookmark actions to the actionCollection so that they show up in the
-shortcusts editor.
-
-Move the code that overrides the add bookmark shortcut, Ctrl+B, to the
-BookmarkMenu class, so that all the relevant code is in one place.
-
-BUG: 419981
----
- src/BookmarkMenu.cpp | 34 +++++++++++++++++++++++++++++-----
- src/BookmarkMenu.h | 2 +-
- src/MainWindow.cpp | 10 ----------
- 3 files changed, 30 insertions(+), 16 deletions(-)
-
-diff --git a/src/BookmarkMenu.cpp b/src/BookmarkMenu.cpp
-index 77344ad..5b83ece 100644
---- a/src/BookmarkMenu.cpp
-+++ b/src/BookmarkMenu.cpp
-@@ -21,24 +21,48 @@
-
- // Own
- #include "BookmarkMenu.h"
-+#include "Shortcut_p.h"
-
- // KDE
- #include <KActionCollection>
-+#include <kbookmarks_version.h>
-+#include <KBookmarkManager>
-+#include <KBookmark>
-
- // Qt
- #include <QAction>
--#include <KBookmarkManager>
--#include <KBookmark>
-+#include <QMenu>
-
- #include <algorithm> // std::any_of
-
--BookmarkMenu::BookmarkMenu (KBookmarkManager *mgr, KBookmarkOwner *owner, QMenu *parentMenu, KActionCollection *collec) :
-- KBookmarkMenu (mgr, owner, parentMenu, collec)
-+BookmarkMenu::BookmarkMenu (KBookmarkManager *mgr, KBookmarkOwner *owner, QMenu *parentMenu, KActionCollection *collection) :
-+#if KBOOKMARKS_VERSION < QT_VERSION_CHECK(5, 69, 0)
-+ KBookmarkMenu (mgr, owner, parentMenu, collection)
-+#else
-+ KBookmarkMenu (mgr, owner, parentMenu)
-+#endif
- {
-+ QAction *bookmarkAction;
-+#if KBOOKMARKS_VERSION < QT_VERSION_CHECK(5, 69, 0)
-+ bookmarkAction = collection->action(QStringLiteral("add_bookmark"));
-+#else
-+ collection->addActions(parentMenu->actions());
-+
-+ bookmarkAction = addBookmarkAction();
-+#endif
-+
-+ Q_ASSERT(bookmarkAction);
-+
- // We need to hijack the action - note this only hijacks top-level action
-- QAction *bookmarkAction = collec->action(QStringLiteral("add_bookmark"));
- disconnect(bookmarkAction, nullptr, this, nullptr);
- connect(bookmarkAction, &QAction::triggered, this, &BookmarkMenu::maybeAddBookmark);
-+
-+ // replace Ctrl+B shortcut for bookmarks only if user hasn't already
-+ // changed the shortcut; however, if the user changed it to Ctrl+B
-+ // this will still get changed to Ctrl+Shift+B
-+ if (bookmarkAction->shortcut() == QKeySequence(Konsole::ACCEL + Qt::Key_B)) {
-+ collection->setDefaultShortcut(bookmarkAction, Konsole::ACCEL + Qt::SHIFT + Qt::Key_B);
-+ }
- }
-
- void BookmarkMenu::maybeAddBookmark()
-diff --git a/src/BookmarkMenu.h b/src/BookmarkMenu.h
-index a42eab2..fde893c 100644
---- a/src/BookmarkMenu.h
-+++ b/src/BookmarkMenu.h
-@@ -39,7 +39,7 @@ class KONSOLEPRIVATE_EXPORT BookmarkMenu : public KBookmarkMenu
- Q_OBJECT
-
- public:
-- BookmarkMenu (KBookmarkManager *mgr, KBookmarkOwner *owner, QMenu *parentMenu, KActionCollection *collec);
-+ BookmarkMenu (KBookmarkManager *mgr, KBookmarkOwner *owner, QMenu *parentMenu, KActionCollection *collection);
-
- private Q_SLOTS:
- void maybeAddBookmark();
-diff --git a/src/MainWindow.cpp b/src/MainWindow.cpp
-index e33eefb..17545f3 100644
---- a/src/MainWindow.cpp
-+++ b/src/MainWindow.cpp
-@@ -193,16 +193,6 @@ void MainWindow::correctStandardShortcuts()
- if (helpAction != nullptr) {
- actionCollection()->setDefaultShortcut(helpAction, QKeySequence());
- }
--
-- // replace Ctrl+B shortcut for bookmarks only if user hasn't already
-- // changed the shortcut; however, if the user changed it to Ctrl+B
-- // this will still get changed to Ctrl+Shift+B
-- QAction *bookmarkAction = actionCollection()->action(QStringLiteral("add_bookmark"));
-- if ((bookmarkAction != nullptr)
-- && bookmarkAction->shortcut() == QKeySequence(Konsole::ACCEL + Qt::Key_B)) {
-- actionCollection()->setDefaultShortcut(bookmarkAction,
-- Konsole::ACCEL + Qt::SHIFT + Qt::Key_B);
-- }
- }
-
- ViewManager *MainWindow::viewManager() const
---
-cgit v1.1
-