aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwallet-pam
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-09 21:29:26 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 15:14:33 -0300
commit0ec2ff9808ede43c16f344d1ac17cc47f08f6f66 (patch)
treea6ff639f5beaf14f13071fe396af0e09def6eb64 /community/kwallet-pam
parent179ffd1a267fc5f3bd47461de870394619124026 (diff)
downloadaports-0ec2ff9808ede43c16f344d1ac17cc47f08f6f66.tar.bz2
aports-0ec2ff9808ede43c16f344d1ac17cc47f08f6f66.tar.xz
community/kwallet-pam: move from testing
Diffstat (limited to 'community/kwallet-pam')
-rw-r--r--community/kwallet-pam/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/kwallet-pam/APKBUILD b/community/kwallet-pam/APKBUILD
new file mode 100644
index 0000000000..4dbdf2a452
--- /dev/null
+++ b/community/kwallet-pam/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kwallet-pam
+pkgver=5.16.5
+pkgrel=0
+pkgdesc="KWallet PAM integration"
+arch="all"
+url="https://www.kde.org/workspaces/plasmadesktop/"
+license="LGPL-2.1-or-later"
+makedepends="extra-cmake-modules linux-pam-dev libgcrypt-dev socat kwallet-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+options="!check" # No tests available
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="6a3c09b645a193bd5164525c6ca0c807a0adc141566db7436101784fef8def79e121c599a837dac32393f8e5ab2c33a9473a29013d07bd64e6a8eab32308d3d1 kwallet-pam-5.16.5.tar.xz"