aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwallet-pam
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-18 16:13:36 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-20 12:24:41 -0300
commitb3553abc60cd45495f8a252a5a06ca25c6749952 (patch)
tree89dc4e90e78d313a485ccb0fd7264c132d9d4381 /community/kwallet-pam
parent9a177212eb91a159b575312d0824a790ad551adf (diff)
downloadaports-b3553abc60cd45495f8a252a5a06ca25c6749952.tar.bz2
aports-b3553abc60cd45495f8a252a5a06ca25c6749952.tar.xz
community/plasma: upgrade to 5.17.0
Diffstat (limited to 'community/kwallet-pam')
-rw-r--r--community/kwallet-pam/APKBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/community/kwallet-pam/APKBUILD b/community/kwallet-pam/APKBUILD
index 4dbdf2a452..4a4f2b94e9 100644
--- a/community/kwallet-pam/APKBUILD
+++ b/community/kwallet-pam/APKBUILD
@@ -1,18 +1,25 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwallet-pam
-pkgver=5.16.5
+pkgver=5.17.0
pkgrel=0
pkgdesc="KWallet PAM integration"
arch="all"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="LGPL-2.1-or-later"
makedepends="extra-cmake-modules linux-pam-dev libgcrypt-dev socat kwallet-dev"
-source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/kwallet-pam-$pkgver.tar.xz"
options="!check" # No tests available
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -20,7 +27,8 @@ build() {
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="6a3c09b645a193bd5164525c6ca0c807a0adc141566db7436101784fef8def79e121c599a837dac32393f8e5ab2c33a9473a29013d07bd64e6a8eab32308d3d1 kwallet-pam-5.16.5.tar.xz"
+sha512sums="f858ad0889364961bc26af4e2e005951133cfa2902e507e08bc39d5437cc0f01cc72e9155f56c0ba2510a5447c486acc7765c5f152cc419edb318c540e5ef941 kwallet-pam-5.17.0.tar.xz"