aboutsummaryrefslogtreecommitdiffstats
path: root/community/ldc
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-13 01:41:46 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-13 06:42:48 +0000
commit6905892bb35b8120cd728c476cfb34f10ff9e424 (patch)
tree4a80cfef73e14a54d7838da868385f007c576325 /community/ldc
parentc3997536026a15e8f571477b13c24caebccf3ab4 (diff)
downloadaports-6905892bb35b8120cd728c476cfb34f10ff9e424.tar.bz2
aports-6905892bb35b8120cd728c476cfb34f10ff9e424.tar.xz
community/ldc: add bash-completion subpackage
Diffstat (limited to 'community/ldc')
-rw-r--r--community/ldc/APKBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/community/ldc/APKBUILD b/community/ldc/APKBUILD
index 8213a5585b..dcced10c7e 100644
--- a/community/ldc/APKBUILD
+++ b/community/ldc/APKBUILD
@@ -2,21 +2,26 @@
# Maintainer: Mathias LANG <pro.mathias.lang@gmail.com>
pkgname=ldc
pkgver=1.20.1
-pkgrel=4
+pkgrel=5
pkgdesc="The LLVM-based D Compiler"
url="https://github.com/ldc-developers/ldc"
# LDC does not support host compiling on most of the architecture Alpine supports
arch="x86_64"
license="BSD-3-Clause AND BSL-1.0 AND ( Artistic-1.0 OR GPL-2.0-or-later ) AND NCSA AND MIT"
depends="libexecinfo tzdata"
-makedepends="chrpath cmake curl-dev diffutils gdmd llvm10-dev llvm10-static libedit-dev libexecinfo-static zlib-dev"
+makedepends="chrpath cmake curl-dev diffutils gdmd llvm10-dev llvm10-static
+ libedit-dev libexecinfo-static zlib-dev"
checkdepends="bash gdb grep llvm10-test-utils"
# A user might want to install the '-runtime' subpackage when they have
# a dynamically-linked D program.
-subpackages="$pkgname-runtime $pkgname-static $pkgname-dbg"
+subpackages="
+ $pkgname-runtime
+ $pkgname-static
+ $pkgname-dbg
+ $pkgname-bash-completion:bashcomp:noarch"
source="https://github.com/ldc-developers/ldc/releases/download/v$pkgver/ldc-$pkgver-src.tar.gz
- 01-conf.patch
- "
+ 01-conf.patch
+ "
builddir="$srcdir/ldc-$pkgver-src/"
build() {
@@ -59,6 +64,9 @@ build() {
"$builddir"/bin/ldmd2 \
"$builddir"/bin/ldc-build-runtime \
"$builddir"/bin/ldc-prune-cache
+
+ mkdir -p "$pkgdir"/usr/share/bash-completion
+ mv "$pkgdir"/etc/bash_completion.d "$pkgdir"/usr/share/bash-completion/completions
}
check() {