aboutsummaryrefslogtreecommitdiffstats
path: root/community/ldc
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-13 04:40:18 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-13 04:40:18 -0300
commit807d73b45367be365d61c05766f4ed78226bc2bd (patch)
treec2feed668a1f8ed72f2ad1a4a1e168e4921a02ae /community/ldc
parent8d33a7f7db550ac602565611a266adb7a55deb15 (diff)
downloadaports-807d73b45367be365d61c05766f4ed78226bc2bd.tar.bz2
aports-807d73b45367be365d61c05766f4ed78226bc2bd.tar.xz
community/ldc: fix bash-completion subpackage packaging
Diffstat (limited to 'community/ldc')
-rw-r--r--community/ldc/APKBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/community/ldc/APKBUILD b/community/ldc/APKBUILD
index dcced10c7e..88dde923e9 100644
--- a/community/ldc/APKBUILD
+++ b/community/ldc/APKBUILD
@@ -64,9 +64,6 @@ build() {
"$builddir"/bin/ldmd2 \
"$builddir"/bin/ldc-build-runtime \
"$builddir"/bin/ldc-prune-cache
-
- mkdir -p "$pkgdir"/usr/share/bash-completion
- mv "$pkgdir"/etc/bash_completion.d "$pkgdir"/usr/share/bash-completion/completions
}
check() {
@@ -88,6 +85,9 @@ package() {
depends="$pkgname-static=$pkgver-r$pkgrel"
# Use -j1, the install is flaky with too many build jobs
make -j1 DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/share/bash-completion
+ mv "$pkgdir"/etc/bash_completion.d "$pkgdir"/usr/share/bash-completion/completions
}
runtime() {
@@ -112,5 +112,13 @@ static() {
mv "$pkgdir"/usr/lib/*.a "$subpkgdir/usr/lib/"
}
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ amove usr/share/bash-completion/completions
+}
+
sha512sums="bb699999a69de1773a10998c653b5a1b0bce30e39cfcee0e19b036378b28519b3118ac369b341cfd305a8a9bd904564ffffe83f720a62ab4f2c1942c2e26bb53 ldc-1.20.1-src.tar.gz
1a8ec8d75a5d01a1bc41e4b641e0663344fcbc44f3f10287f8cc716095faeadfa3dfc4ce7d84d72522151454e54d95e9f623ec5862e98e837d8fe44057307ce9 01-conf.patch"