aboutsummaryrefslogtreecommitdiffstats
path: root/community/ldc
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-23 14:31:02 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-23 14:03:39 +0000
commitb3885777f00606b1f3e553143ad336afa267a46e (patch)
treef29435d69dadfdb8b3ccda967ed19df5a62518d8 /community/ldc
parentd536dcc85aa04b1efb46ce50a58b7edd4c5f0c02 (diff)
downloadaports-b3885777f00606b1f3e553143ad336afa267a46e.tar.bz2
aports-b3885777f00606b1f3e553143ad336afa267a46e.tar.xz
community/ldc: remove RPATH from binaries
We need to set LD_LIBRARY_PATH for tests now though, since the rpath did for for us previously.
Diffstat (limited to 'community/ldc')
-rw-r--r--community/ldc/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/community/ldc/APKBUILD b/community/ldc/APKBUILD
index ec9cc92d09..eb500c5ef8 100644
--- a/community/ldc/APKBUILD
+++ b/community/ldc/APKBUILD
@@ -52,9 +52,15 @@ build() {
# CMake added the rpaths to the shared libs - strip them
chrpath -d "$builddir"/lib/*.so*
+ chrpath -d \
+ "$builddir"/bin/ldc2 \
+ "$builddir"/bin/ldmd2 \
+ "$builddir"/bin/ldc-build-runtime \
+ "$builddir"/bin/ldc-prune-cache
}
check() {
+ export LD_LIBRARY_PATH="$builddir"/lib
# Note: The testsuite does not parallelize well, as the 'clean' target get run in parallel.
# Hence '-j${JOBS}' was left out on purpose
#
@@ -70,7 +76,8 @@ check() {
package() {
depends="$pkgname-static=$pkgver-r$pkgrel"
- make DESTDIR="$pkgdir" install
+ # Use -j1, the install is flaky with too many build jobs
+ make -j1 DESTDIR="$pkgdir" install
}
runtime() {