aboutsummaryrefslogtreecommitdiffstats
path: root/community/ldc
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-04-15 09:35:01 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-15 09:13:23 +0000
commite66cab8bbad7837c24e8d95952e235fb01c4c676 (patch)
tree3c04e6a393db1d15d45e99ddd89a1fac09f1d48d /community/ldc
parentb055f86da0f38d48291d11dde2eb841d04d9f6a6 (diff)
downloadaports-e66cab8bbad7837c24e8d95952e235fb01c4c676.tar.bz2
aports-e66cab8bbad7837c24e8d95952e235fb01c4c676.tar.xz
community/ldc: enable on x86
fixes #11306
Diffstat (limited to 'community/ldc')
-rw-r--r--community/ldc/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/ldc/APKBUILD b/community/ldc/APKBUILD
index 71f5f57484..95c372c972 100644
--- a/community/ldc/APKBUILD
+++ b/community/ldc/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=5
pkgdesc="The LLVM-based D Compiler"
url="https://github.com/ldc-developers/ldc"
# LDC does not support host compiling on most of the architecture Alpine supports
-arch="x86_64 aarch64"
+arch="x86 x86_64 aarch64"
license="BSD-3-Clause AND BSL-1.0 AND ( Artistic-1.0 OR GPL-2.0-or-later ) AND NCSA AND MIT"
depends="libexecinfo tzdata"
makedepends="chrpath cmake curl-dev diffutils gdmd llvm10-dev llvm10-static
@@ -78,6 +78,10 @@ check() {
aarch64)
_tests_ignore="|core\.thread\.fiber|std.*math.*|std\.numeric.*|std\.format|std\.algorithm\.sorting.*|druntime-test-thread"
;;
+ # https://github.com/ldc-developers/ldc/issues/3404
+ x86)
+ _tests_ignore="|druntime-test-thread"
+ ;;
esac