aboutsummaryrefslogtreecommitdiffstats
path: root/community/lego
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-22 12:49:46 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-22 12:50:32 +0100
commit713303885caff9cb846c21d89604375741cdc430 (patch)
tree07992b3a54b5b05cc45c3f85c9f43c4f65a1e021 /community/lego
parent021175b0a706f15cb1999bb72a290a7e6caf6a38 (diff)
downloadaports-713303885caff9cb846c21d89604375741cdc430.tar.bz2
aports-713303885caff9cb846c21d89604375741cdc430.tar.xz
community/lego: move to testing due to violation of QA rules
`go get` must not be used in APKBUILD, it downloads random dependencies from Internet without any verification, leads to unreproducible build
Diffstat (limited to 'community/lego')
-rw-r--r--community/lego/APKBUILD65
-rw-r--r--community/lego/b5d5eee2dd269f88f181d7a437be80194bfd0235.patch86
-rw-r--r--community/lego/use-correct-version.patch11
3 files changed, 0 insertions, 162 deletions
diff --git a/community/lego/APKBUILD b/community/lego/APKBUILD
deleted file mode 100644
index fcc07c769f..0000000000
--- a/community/lego/APKBUILD
+++ /dev/null
@@ -1,65 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
-pkgname=lego
-pkgver=0.3.1
-pkgrel=1
-pkgdesc="Let's Encrypt client and ACME library written in Go"
-url="https://github.com/xenolf/lego"
-arch="all"
-license="MIT"
-depends="ca-certificates"
-depends_dev=""
-makedepends="$depends_dev go git libcap"
-subpackages=""
-source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
- use-correct-version.patch
- b5d5eee2dd269f88f181d7a437be80194bfd0235.patch
- "
-
-_disturl="dev.alpinelinux.org:/archive/$pkgname/"
-_gourl="github.com/xenolf/lego"
-
-builddir="$srcdir"/src/$_gourl
-
-snapshot() {
- abuild clean && abuild deps
- export GOPATH="$srcdir"
- msg "Checking out v${pkgver} tag"
- # go get will not checkout a specific tag
- # so we run our own git checkout branch
- git clone --quiet --branch v${pkgver} \
- https://$_gourl $builddir || return 1
- cd $builddir
- # fetch deps
- go get -v -d || return 1
- cd "$srcdir"
- tar zcf $pkgname-$pkgver.tar.gz src || return 1
- rsync --progress -La $pkgname-$pkgver.tar.gz \
- $_disturl || return 1
- cd $startdir && abuild undeps
-}
-
-build() {
- cd "$builddir" || return 1
- export GOPATH="$srcdir"
- go build -v -o e${pkgname} || return 1
-}
-
-package() {
- cd "$builddir"
- install -Dm755 e${pkgname} \
- "$pkgdir"/usr/bin/lego || return 1
- # allow non root to use priv ports
- setcap cap_net_bind_service=+ep \
- "$pkgdir"/usr/bin/lego || return 1
-}
-
-md5sums="cd29925f21c9cfec355a77e568237572 lego-0.3.1.tar.gz
-360a5fc558fd26617f85ebda7a19ebdd use-correct-version.patch
-ec144bfd625e0ad1859d96e788965dd1 b5d5eee2dd269f88f181d7a437be80194bfd0235.patch"
-sha256sums="6cd667f9506c15e2b3d845af495ed7ed4e0402813ebe00ce4bf0065463e1d9ff lego-0.3.1.tar.gz
-1a4be6a44647648e045a4ff1fe91de8e8a7fc0d9acee890ae032a9e0477f25f8 use-correct-version.patch
-e887ba93c8c4151de253cec5a669fbb0ac29d6e035a58e464e0f6bc10a8713f4 b5d5eee2dd269f88f181d7a437be80194bfd0235.patch"
-sha512sums="982319eaca5e3544dbe29ccafef8b0f3a87f8c7cdfb645565a02e11c4beda81e5b617c5a431a4b0b49c9808c3ed4a318626d6912628ec24d48976d15b99dd117 lego-0.3.1.tar.gz
-0c48d76a504ce6f4dab496a317f2b273203d761539b217c8c666d956b9855f94f8645654f7e7a84ccbe6c4d24d1b9c96ff2e93e459f36927866025ce9037a5b4 use-correct-version.patch
-5c24227372e32294c8a38061b1c8c53cb715d24db23bd315efb017fbbc8374cae3010da2d8779bee8c6ebf737a255837264e24cbb4efe03a14597721217fc4f6 b5d5eee2dd269f88f181d7a437be80194bfd0235.patch"
diff --git a/community/lego/b5d5eee2dd269f88f181d7a437be80194bfd0235.patch b/community/lego/b5d5eee2dd269f88f181d7a437be80194bfd0235.patch
deleted file mode 100644
index b039ebf074..0000000000
--- a/community/lego/b5d5eee2dd269f88f181d7a437be80194bfd0235.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-From b5d5eee2dd269f88f181d7a437be80194bfd0235 Mon Sep 17 00:00:00 2001
-From: xenolf <xenolf@users.noreply.github.com>
-Date: Thu, 12 May 2016 19:52:59 +0200
-Subject: [PATCH] Update usage of codegangster/cli to remove deprecation
- warning. Fixes #206.
-
----
- cli.go | 4 +++-
- cli_handlers.go | 14 ++++++++++----
- 2 files changed, 13 insertions(+), 5 deletions(-)
-
-diff --git a/cli.go b/cli.go
-index 052fc76..10cd705 100644
---- a/cli.go
-+++ b/cli.go
-@@ -144,7 +144,7 @@ func main() {
- app.Run(os.Args)
- }
-
--func dnshelp(c *cli.Context) {
-+func dnshelp(c *cli.Context) error {
- fmt.Printf(
- `Credentials for DNS providers must be passed through environment variables.
-
-@@ -175,4 +175,6 @@ Here is an example bash command using the CloudFlare DNS provider:
- fmt.Println(`
- For a more detailed explanation of a DNS provider's credential variables,
- please consult their online documentation.`)
-+
-+ return nil
- }
-diff --git a/cli_handlers.go b/cli_handlers.go
-index 1601c43..5585bcf 100644
---- a/cli_handlers.go
-+++ b/cli_handlers.go
-@@ -196,7 +196,7 @@ func handleTOS(c *cli.Context, client *acme.Client, acc *Account) {
- }
- }
-
--func run(c *cli.Context) {
-+func run(c *cli.Context) error {
- conf, acc, client := setup(c)
- if acc.Registration == nil {
- reg, err := client.Register()
-@@ -245,9 +245,11 @@ func run(c *cli.Context) {
- }
-
- saveCertRes(cert, conf)
-+
-+ return nil
- }
-
--func revoke(c *cli.Context) {
-+func revoke(c *cli.Context) error {
-
- conf, _, client := setup(c)
-
-@@ -269,9 +271,11 @@ func revoke(c *cli.Context) {
- logger().Print("Certificate was revoked.")
- }
- }
-+
-+ return nil
- }
-
--func renew(c *cli.Context) {
-+func renew(c *cli.Context) error {
- conf, _, client := setup(c)
-
- if len(c.GlobalStringSlice("domains")) <= 0 {
-@@ -299,7 +303,7 @@ func renew(c *cli.Context) {
- }
-
- if int(expTime.Sub(time.Now()).Hours()/24.0) > c.Int("days") {
-- return
-+ return nil
- }
- }
-
-@@ -330,4 +334,6 @@ func renew(c *cli.Context) {
- }
-
- saveCertRes(newCert, conf)
-+
-+ return nil
- }
diff --git a/community/lego/use-correct-version.patch b/community/lego/use-correct-version.patch
deleted file mode 100644
index 5dae0fd875..0000000000
--- a/community/lego/use-correct-version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./cli.go.orig
-+++ ./cli.go
-@@ -32,7 +32,7 @@
- app.Name = "lego"
- app.Usage = "Let's Encrypt client written in Go"
-
-- version := "0.3.0"
-+ version := "0.3.1"
- if strings.HasPrefix(gittag, "v") {
- version = gittag
- }