aboutsummaryrefslogtreecommitdiffstats
path: root/community/lensfun
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-06-22 16:32:09 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-06-22 16:32:09 +0000
commit0d9e56864a43e3fe1e5c03c1f98604fc18d98366 (patch)
tree4a2e6002088bb1b54a4615603557347e06aaaf48 /community/lensfun
parent94ec31cb8ecc18f64599c4c15839359f25aa6da0 (diff)
downloadaports-0d9e56864a43e3fe1e5c03c1f98604fc18d98366.tar.bz2
aports-0d9e56864a43e3fe1e5c03c1f98604fc18d98366.tar.xz
community/lensfun: upgrade to 0.3.2
Diffstat (limited to 'community/lensfun')
-rw-r--r--community/lensfun/APKBUILD32
1 files changed, 11 insertions, 21 deletions
diff --git a/community/lensfun/APKBUILD b/community/lensfun/APKBUILD
index 7ef8a8c06e..1ac5d3bdaf 100644
--- a/community/lensfun/APKBUILD
+++ b/community/lensfun/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=lensfun
-pkgver=0.3.1
+pkgver=0.3.2
pkgrel=0
pkgdesc="Image manipulation library to rectify lens defects."
url="http://lensfun.sourceforge.net/"
@@ -11,40 +11,30 @@ depends=""
depends_dev=""
makedepends="py-docutils cmake doxygen libpng glib-dev"
install=""
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-dev"
source="http://downloads.sourceforge.net/project/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
-
-_builddir=${srcdir}/${pkgname}-${pkgver}
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir=${srcdir}/${pkgname}-${pkgver}
build() {
- cd "$_builddir"
+ cd "$builddir"
local opts=
case "$CARCH" in
arm*) opts="-DBUILD_FOR_SSE=OFF -DBUILD_FOR_SSE2=OFF";;
esac
cmake \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_DOC=On \
- -DLENSFUN_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
$opts \
|| return 1
make all || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
}
-md5sums="7f577385f98b260ea5384b99c6eb03aa lensfun-0.3.1.tar.gz"
-sha256sums="216c23754212e051c8b834437e46af3812533bd770c09714e8c06c9d91cdb535 lensfun-0.3.1.tar.gz"
-sha512sums="cd0f142bb7d6aa154f587d89502da35473a7a02660246bd025ccd5d1982f55425359405898e11ce9094351ad44a2d6786b9ff07d227f75699e99e4de8f40938c lensfun-0.3.1.tar.gz"
+md5sums="247e59a0812ec451f6cd0d20b3379cb5 lensfun-0.3.2.tar.gz"
+sha256sums="ae8bcad46614ca47f5bda65b00af4a257a9564a61725df9c74cb260da544d331 lensfun-0.3.2.tar.gz"
+sha512sums="9c6f546fa70e6dc692e66ef378447345be6d3383812934780d326d772d775c1918cbf3447cd91c067655044cf659025763bf47ba2d938a82a3c2de4d60127446 lensfun-0.3.2.tar.gz"