aboutsummaryrefslogtreecommitdiffstats
path: root/community/lensfun
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-19 23:51:38 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-19 23:57:53 +0100
commit58df1e6319cbec7e4e1a9771525b97bf923c6557 (patch)
treeeb48725f7e133ef265d5c87c0dfb1153fdb375fc /community/lensfun
parent0cce53e8d330d6c4c97209e636cca6d34063a284 (diff)
downloadaports-58df1e6319cbec7e4e1a9771525b97bf923c6557.tar.bz2
aports-58df1e6319cbec7e4e1a9771525b97bf923c6557.tar.xz
community/lensfun: use py3-docutils
Diffstat (limited to 'community/lensfun')
-rw-r--r--community/lensfun/APKBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/community/lensfun/APKBUILD b/community/lensfun/APKBUILD
index 0e73c8761e..25bc823084 100644
--- a/community/lensfun/APKBUILD
+++ b/community/lensfun/APKBUILD
@@ -2,40 +2,36 @@
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=lensfun
pkgver=0.3.2
-pkgrel=0
+pkgrel=1
pkgdesc="Image manipulation library to rectify lens defects"
url="http://lensfun.sourceforge.net/"
arch="all"
-license="LGPL-3.0"
-makedepends="py-docutils cmake doxygen libpng glib-dev"
+license="LGPL-3.0-or-later"
+makedepends="py3-docutils cmake doxygen libpng glib-dev"
subpackages="$pkgname-dev"
-source="https://downloads.sourceforge.net/project/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://downloads.sourceforge.net/project/lensfun/$pkgver/lensfun-$pkgver.tar.gz"
build() {
- cd "$builddir"
-
local opts=""
case "$CARCH" in
x86*) ;;
*) opts="-DBUILD_FOR_SSE=OFF -DBUILD_FOR_SSE2=OFF";;
esac
+ ln -s /usr/bin/rst2man-3 rst2man
+ export PATH="$PATH":.
+
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- $opts \
- || return 1
+ $opts
make all
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-md5sums="247e59a0812ec451f6cd0d20b3379cb5 lensfun-0.3.2.tar.gz"
-sha256sums="ae8bcad46614ca47f5bda65b00af4a257a9564a61725df9c74cb260da544d331 lensfun-0.3.2.tar.gz"
sha512sums="9c6f546fa70e6dc692e66ef378447345be6d3383812934780d326d772d775c1918cbf3447cd91c067655044cf659025763bf47ba2d938a82a3c2de4d60127446 lensfun-0.3.2.tar.gz"