aboutsummaryrefslogtreecommitdiffstats
path: root/community/lensfun
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-23 10:36:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-23 10:47:15 +0000
commitb0d3909bffb7f6b6a91c0b2bf5d1a7eeac811ae2 (patch)
treea2d509dc628c62dd9650b01896adfe21c980c059 /community/lensfun
parent75590761e7f6cb24c571c407a872c3d502948505 (diff)
downloadaports-b0d3909bffb7f6b6a91c0b2bf5d1a7eeac811ae2.tar.bz2
aports-b0d3909bffb7f6b6a91c0b2bf5d1a7eeac811ae2.tar.xz
community/lensfun: move from main
Diffstat (limited to 'community/lensfun')
-rw-r--r--community/lensfun/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/community/lensfun/APKBUILD b/community/lensfun/APKBUILD
new file mode 100644
index 0000000000..7ef8a8c06e
--- /dev/null
+++ b/community/lensfun/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=lensfun
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="Image manipulation library to rectify lens defects."
+url="http://lensfun.sourceforge.net/"
+arch="all"
+license="LGPL3"
+depends=""
+depends_dev=""
+makedepends="py-docutils cmake doxygen libpng glib-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/project/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+
+_builddir=${srcdir}/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ local opts=
+ case "$CARCH" in
+ arm*) opts="-DBUILD_FOR_SSE=OFF -DBUILD_FOR_SSE2=OFF";;
+ esac
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_DOC=On \
+ -DLENSFUN_INSTALL_PREFIX=/usr \
+ $opts \
+ || return 1
+ make all || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ }
+
+md5sums="7f577385f98b260ea5384b99c6eb03aa lensfun-0.3.1.tar.gz"
+sha256sums="216c23754212e051c8b834437e46af3812533bd770c09714e8c06c9d91cdb535 lensfun-0.3.1.tar.gz"
+sha512sums="cd0f142bb7d6aa154f587d89502da35473a7a02660246bd025ccd5d1982f55425359405898e11ce9094351ad44a2d6786b9ff07d227f75699e99e4de8f40938c lensfun-0.3.1.tar.gz"