aboutsummaryrefslogtreecommitdiffstats
path: root/community/leveldb
diff options
context:
space:
mode:
authoriggy <iggy@theiggy.com>2019-04-13 11:40:19 -0700
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-15 10:52:13 +0000
commit4c5ee31595c3d2906f7681dfc582cd89e688a54e (patch)
tree60c7fda71933c06962befe538020f3590b691c93 /community/leveldb
parentfb7dac9ae86ff3b7918d6a2b3c615457fb521a6c (diff)
downloadaports-4c5ee31595c3d2906f7681dfc582cd89e688a54e.tar.bz2
aports-4c5ee31595c3d2906f7681dfc582cd89e688a54e.tar.xz
community/leveldb: move from testing
Required as a dependency of ceph.
Diffstat (limited to 'community/leveldb')
-rw-r--r--community/leveldb/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/leveldb/APKBUILD b/community/leveldb/APKBUILD
new file mode 100644
index 0000000000..66ab128c63
--- /dev/null
+++ b/community/leveldb/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=leveldb
+pkgver=1.20
+pkgrel=1
+pkgdesc="A fast and lightweight key/value database library by Google"
+url="https://github.com/google/leveldb"
+arch="all"
+license="BSD"
+makedepends="snappy-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/google/$pkgname/archive/v$pkgver.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/lib "$pkgdir"/usr/share/doc
+ cp -a out-shared/lib*.so* "$pkgdir"/usr/lib
+ cp -a include "$pkgdir"/usr/
+ cp -a doc "$pkgdir"/usr/share/doc/$pkgname
+
+}
+
+sha512sums="c59258f2f58ce2d5680e9ab3da4ab0923d91cd4648dcf63cdaa26cdde92bf45e094544539ad11d8e09a4a4813435286143ed0e86c21c6c31a0596903ed4744d2 leveldb-1.20.tar.gz"