aboutsummaryrefslogtreecommitdiffstats
path: root/community/libatasmart
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:26:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-23 12:07:30 -0300
commit41ab224df12b8487004a1522b4f671680c082954 (patch)
tree9ebbc4ea5d1cfb82757ca1fd862b67e444a712a2 /community/libatasmart
parent1f40937c55d742c7ae05db34c966c3dd2d6595e7 (diff)
downloadaports-41ab224df12b8487004a1522b4f671680c082954.tar.bz2
aports-41ab224df12b8487004a1522b4f671680c082954.tar.xz
community/*: move lots of stuff from main and modernize
Diffstat (limited to 'community/libatasmart')
-rw-r--r--community/libatasmart/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/libatasmart/APKBUILD b/community/libatasmart/APKBUILD
new file mode 100644
index 0000000000..824d47c4ef
--- /dev/null
+++ b/community/libatasmart/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Carlo Landmeter
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libatasmart
+pkgver=0.19
+pkgrel=1
+pkgdesc="ATA S.M.A.R.T. Reading and Parsing Library"
+url="http://0pointer.de/blog/projects/being-smart.html"
+arch="all"
+options="!check" # No test suite.
+license="LGPL-2.1-or-later"
+depends_dev="eudev-dev"
+makedepends="$depends_dev linux-headers"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://0pointer.de/public/libatasmart-$pkgver.tar.xz"
+
+prepare() {
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-static \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="ec9edb019c477873b01289ba365ad0ed0946505d651c1f6f83a63ef61b3976a5db6439c8a0c74d9a55325db9a3a587ad6f655f8d1af9387b0d08356eccabdb62 libatasmart-0.19.tar.xz"