aboutsummaryrefslogtreecommitdiffstats
path: root/community/libcec/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-02-26 21:54:50 +0200
committerprspkt <prspkt@protonmail.com>2019-02-26 23:32:25 +0200
commitb4eafe396c7cb9ab97e86af9b12f1b06aa1ef464 (patch)
tree1a8b09e73184477e130fba97d4fcbabcdffbd2bb /community/libcec/APKBUILD
parent5075582b1544bfe9c33386943f72ff9bd74e2a98 (diff)
downloadaports-b4eafe396c7cb9ab97e86af9b12f1b06aa1ef464.tar.bz2
aports-b4eafe396c7cb9ab97e86af9b12f1b06aa1ef464.tar.xz
community/libcec: clarify license, modernize
Diffstat (limited to 'community/libcec/APKBUILD')
-rw-r--r--community/libcec/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/community/libcec/APKBUILD b/community/libcec/APKBUILD
index 1d789c6fe9..8fdccb5195 100644
--- a/community/libcec/APKBUILD
+++ b/community/libcec/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=1
pkgdesc="libcec for the Pulse-Eight USB-CEC adapter"
url="https://github.com/Pulse-Eight/libcec"
arch="all"
-license="GPL"
+license="GPL-2.0-or-later"
depends=""
depends_dev="eudev-dev python3-dev libxrandr-dev swig"
makedepends="$depends_dev p8-platform-dev cmake"
@@ -29,19 +29,17 @@ build() {
cmake -DCMAKE_BUILD_TYPE=Release \
-DBUILD_SHARED_LIBS=1 \
-DCMAKE_INSTALL_PREFIX=/usr \
- .. || return 1
- make || return 1
+ ..
+ make
}
package() {
cd "$builddir/build"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
# Add cec directory to sys.path to get rid of issue https://github.com/Pulse-Eight/libcec/issues/316
python_dir=$(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")
echo "cec" > "${pkgdir}${python_dir}/cec.pth"
}
-md5sums="47892140fbda566f6a6f944b52eb44fd libcec-4.0.2.tar.gz"
-sha256sums="b8b8dd31f3ebdd5472f03ab7d401600ea0d959b1288b9ca24bf457ef60e2ba27 libcec-4.0.2.tar.gz"
sha512sums="7bb80965cd1bef713f59bff136dc4a7f1172c4a9bdb8e2f59c6bcc5b74110848c0b2912263280ea68177908a688127e8d7208fc43ce6e65d589343b85395a0bb libcec-4.0.2.tar.gz"